]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-ide-support: Add native qemu support for meta-ide-support
authorJessica Zhang <jessica.zhang@intel.com>
Mon, 16 Jul 2012 22:29:07 +0000 (15:29 -0700)
committerSaul Wold <sgw@linux.intel.com>
Wed, 18 Jul 2012 07:34:37 +0000 (00:34 -0700)
[YOCTO #2761]

This patch fixed the issue that after "bitbake meta-ide-support" and try to start qemu and it will fail.  This is due to the meta-ide-support lacking dependency for qemu native and ended up using qemu under /usr/bin.  Fix the issue by adding dependency for qemu native in meta-ide-support and also add the path info in the environment-setup script.

Signed-off-by: Jessica Zhang <jessica.zhang@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/classes/toolchain-scripts.bbclass
meta/recipes-core/meta/meta-ide-support.bb

index bf37ec9ac8641b02a1d2094ce620ca7092316972..e5e5e96a7b55466b01d3e683f272a893b20b2822 100644 (file)
@@ -52,7 +52,7 @@ toolchain_create_tree_env_script () {
        script=${TMPDIR}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}
        rm -f $script
        touch $script
-       echo 'export PATH=${PATH}' >> $script
+       echo 'export PATH=${STAGING_DIR_NATIVE}/usr/bin:${PATH}' >> $script
        echo 'export PKG_CONFIG_SYSROOT_DIR=${PKG_CONFIG_SYSROOT_DIR}' >> $script
        echo 'export PKG_CONFIG_PATH=${PKG_CONFIG_PATH}' >> $script
 
index 326b25a09c63253b167d64d3c6657775eaea2fbd..130b1c94941dfbf62f509b9424ddae206eb16c61 100644 (file)
@@ -3,8 +3,8 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
-DEPENDS = "virtual/libc gdb-cross qemu-helper-native unfs-server-native"
-PR = "r2"
+DEPENDS = "virtual/libc gdb-cross qemu-native qemu-helper-native unfs-server-native"
+PR = "r3"
 
 inherit meta toolchain-scripts