]> code.ossystems Code Review - openembedded-core.git/commitdiff
btrfs-tools:Fix multithreaded building
authorNitin A Kamble <nitin.a.kamble@intel.com>
Mon, 2 Jan 2012 19:29:30 +0000 (11:29 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 Jan 2012 12:10:52 +0000 (12:10 +0000)
Fixes bug: [YOCTO #1524]

Fixes this error with make -j:
btrfsctl.c
| i586-poky-linux-gcc  -m32   -march=i586
--sysroot=/intel/poky/builds/world/tmp/sysroots/qemux86
-Wp,-MMD,./.btrfsctl.o.d,-MT,btrfsctl.o -Wall -D_FILE_OFFSET_BITS=64
-D_FORTIFY_SOURCE=2 -O2 -pipe -g -feliminate-unused-debug-types -c
btrfsctl.c
| btrfsctl.c:37:21: fatal error: version.h: No such file or directory
| compilation terminated.
| btrfslabel.c:40:21: fatal error: version.h: No such file or directory
| compilation terminated.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch [new file with mode: 0644]
meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb

diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch b/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch
new file mode 100644 (file)
index 0000000..40175b8
--- /dev/null
@@ -0,0 +1,36 @@
+Upstream-Status: Pending
+
+Fix makefile for multithreaded (make -j ) building.
+
+btrfsctl.c
+| i586-poky-linux-gcc  -m32   -march=i586 --sysroot=/intel/poky/builds/world/tmp/sysroots/qemux86 -Wp,-MMD,./.btrfsctl.o.d,-MT,btrfsctl.o -Wall -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -O2 -pipe -g -feliminate-unused-debug-types -c btrfsctl.c
+| btrfsctl.c:37:21: fatal error: version.h: No such file or directory
+| compilation terminated.
+| btrfslabel.c:40:21: fatal error: version.h: No such file or directory
+| compilation terminated.
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/01/02
+
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -26,14 +26,13 @@ else
+       check = ls
+ endif
+-.c.o:
++%.o: %.c version.h
+       $(check) $<
+       $(CC) $(DEPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c $<
++all: $(progs) manpages
+-all: version $(progs) manpages
+-
+-version:
++version.h: version.sh
+       bash version.sh
+ btrfs: $(objects) btrfs.o btrfs_cmds.o scrub.o
index b2e503bda6d4fbd72646647b53da0144a1b9e27b..58049e5f785a2219f5d9371deb046bcd2c57d84b 100644 (file)
@@ -16,10 +16,12 @@ SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs.git;p
 
 S = "${WORKDIR}/git"
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI += " file://fix_use_of_gcc.patch \
-        file://weak-defaults.patch "
+        file://weak-defaults.patch \
+        file://fix_race_condition_with_multithreaded_make.patch "
+
 SRC_URI[md5sum] = "78b1700d318de8518abfaab71f99a885"
 SRC_URI[sha256sum] = "1285774e0cb72984fac158dd046c8d405324754febd30320cd31e459253e4b65"