]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipes: add distro_features_check for some packages
authorWenzong Fan <wenzong.fan@windriver.com>
Wed, 21 Oct 2015 08:23:55 +0000 (04:23 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Nov 2015 11:14:38 +0000 (11:14 +0000)
* The packages that depends on gtk+3 require any of distro features
  from ${GTK3DISTROFEATURES}

* The packages that depends on virtual/egl, virtual/libgl ... require
  distro feature 'opengl'

Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
13 files changed:
meta/recipes-gnome/gcr/gcr_3.16.0.bb
meta/recipes-gnome/libnotify/libnotify_0.7.6.bb
meta/recipes-graphics/clutter/clutter-1.0.inc
meta/recipes-graphics/clutter/clutter-gst-3.0.inc
meta/recipes-graphics/clutter/clutter-gtk-1.0.inc
meta/recipes-graphics/cogl/cogl-1.0.inc
meta/recipes-graphics/eglinfo/eglinfo.inc
meta/recipes-graphics/libepoxy/libepoxy_git.bb
meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
meta/recipes-graphics/mx/mx.inc
meta/recipes-graphics/packagegroups/packagegroup-core-clutter.bb
meta/recipes-graphics/wayland/weston-init.bb
meta/recipes-graphics/wayland/weston_1.8.0.bb

index 4c9fe2ec89e8fea73af8e3fda01b20e6b0f4376b..057c8156541c6b607a8e3d606a2bb6ccc19e7001 100644 (file)
@@ -7,7 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
 
 DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt vala"
 
-inherit autotools gnomebase gtk-icon-cache gtk-doc
+inherit autotools gnomebase gtk-icon-cache gtk-doc distro_features_check
+# depends on gtk+3
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
 
 SRC_URI[archive.md5sum] = "d5835680be0b6a838e02a528d5378d9c"
 SRC_URI[archive.sha256sum] = "ecfe8df41cc88158364bb15addc670b11e539fe844742983629ba2323888d075"
index 41d188cadd417f95c31d76856243cdc02048d28c..1a24c1073e97ac55ec1da30c7f1e43ec1b2607cf 100644 (file)
@@ -5,7 +5,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
 
 DEPENDS = "dbus gtk+3 dbus-glib"
 
-inherit gnomebase gtk-doc
+inherit gnomebase gtk-doc distro_features_check
+# depends on gtk+3
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
 
 SRC_URI[archive.md5sum] = "a4997019d08f46f3bf57b78e6f795a59"
 SRC_URI[archive.sha256sum] = "0ef61ca400d30e28217979bfa0e73a7406b19c32dd76150654ec5b2bdf47d837"
index da21cee8b58a1d9816cc51c1de2201ade6bacfc8..5d0f55c64d500ffd96ab31a7f58c64f794f558d6 100644 (file)
@@ -2,7 +2,9 @@ SUMMARY = "Graphics library for creating hardware-accelerated user interfaces"
 HOMEPAGE = "http://www.clutter-project.org/"
 LICENSE = "LGPLv2.1+"
 
-inherit clutter ptest-gnome
+inherit clutter ptest-gnome distro_features_check
+# depends on cogl-1.0 which needs opengl
+REQUIRED_DISTRO_FEATURES ?= "opengl"
 
 DEPENDS = "pango glib-2.0 json-glib atk udev cogl-1.0"
 PACKAGE_BEFORE_PN += "${PN}-examples"
index d4fed7127f3c9535932eb6be1f97593bf6b61ee4..67c75902ef3251cef9e50e63a2835ac9abfa6fb3 100644 (file)
@@ -2,7 +2,9 @@ SUMMARY = "GStreamer integration library for Clutter"
 HOMEPAGE = "http://www.clutter-project.org/"
 LICENSE = "LGPLv2+"
 
-inherit clutter
+inherit clutter distro_features_check
+# depends on clutter-1.0 which depends on cogl-1.0
+REQUIRED_DISTRO_FEATURES ?= "opengl"
 
 SRC_URI += "file://0001-Install-example-binary-needed-for-core-image-clutter.patch"
 
index 45898b4d60da660086c5327b0b6ff4f1f301c99f..688eed2d91e59295063c68b55d544081266d5101 100644 (file)
@@ -2,7 +2,11 @@ SUMMARY = "Library for embedding a Clutter canvas in a GTK+ application"
 HOMEPAGE = "http://www.clutter-project.org/"
 LICENSE = "LGPLv2+"
 
-inherit clutter
+inherit clutter distro_features_check
+# depends on clutter-1.0 which depends on cogl-1.0
+REQUIRED_DISTRO_FEATURES ?= "opengl"
+# depends on gtk+3
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
 
 DEPENDS = "clutter-1.0 gtk+3"
 PACKAGES  =+ "${PN}-examples"
index 3da31c85fd739ec6ea1fe9d5ad11551297b4374a..88d84ea5fee6087b7cd609de2dfb9f1455d60351 100644 (file)
@@ -2,7 +2,9 @@ SUMMARY = "Modern 3D graphics API with associated utility APIs"
 HOMEPAGE = "http://wiki.clutter-project.org/wiki/Cogl"
 LICENSE = "MIT"
 
-inherit clutter
+inherit clutter distro_features_check
+# cogl-1.0 needs opengl to build
+REQUIRED_DISTRO_FEATURES ?= "opengl"
 
 DEPENDS = "glib-2.0 gdk-pixbuf"
 PACKAGES =+ "${PN}-examples \
index b87688af7235cd5c8716400c968cc355c9c4afc0..fb891755db87e92f77016a464a22f42740638aef 100644 (file)
@@ -11,7 +11,9 @@ SRCREV = "4b317648ec6cf39556a9e5d8078f605bc0edd5de"
 
 S = "${WORKDIR}/git"
 
-inherit waf
+inherit waf distro_features_check
+# depends on virtual/egl
+REQUIRED_DISTRO_FEATURES ?= "opengl"
 
 # BSP layers should add .bbappend files for the -x11 and -fb .bb recipes, which
 # append the respective EGL/OpenGLES/OpenVG libraries to DEPENDS and set
index ad1729383e30f45ff0e73a4001ec3973569fccb5..6c247ccafec2e8115b288af18464696481138bc5 100644 (file)
@@ -17,7 +17,9 @@ PV = "1.3.1"
 
 S = "${WORKDIR}/git"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/egl
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 DEPENDS = "util-macros virtual/egl"
 
index 0094f556f9f1c3ea099f98841f59910c35136a14..557b8c65db91d16669b750d4a8f16450297b3454 100644 (file)
@@ -24,7 +24,9 @@ SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/demos/${PV}/${BPN}-${PV}.tar.bz2 \
 SRC_URI[md5sum] = "72613a2c8c013716db02e3ff59d29061"
 SRC_URI[sha256sum] = "e4bfecb5816ddd4b7b37c1bc876b63f1f7f06fda5879221a9774d0952f90ba92"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/egl, virtual/libgl ...
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
                   ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew glu', '', d)}"
index ee7f18623cb9401e9770dece23cdb55cac5d73fc..aa4915d25c428fd64043d17956c6c8f99e944a11 100644 (file)
@@ -1,7 +1,9 @@
 SUMMARY = "Clutter based UI widget library"
 LICENSE = "LGPLv2.1"
 
-inherit clutter autotools-brokensep
+inherit clutter autotools-brokensep distro_features_check
+# depends on clutter-1.0 which depends on cogl-1.0
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 DEPENDS = "clutter-1.0 dbus-glib gdk-pixbuf"
 
index 9d67e5f89ca59721299c90d953ccfea66ca78093..5734b2785f4bc969db167077d3abb8a86941b0f5 100644 (file)
@@ -7,7 +7,9 @@ LICENSE = "MIT"
 
 PR = "r6"
 
-inherit packagegroup
+inherit packagegroup distro_features_check
+# rdepends on clutter-*
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 PACKAGES = "\
     ${PN}-core \
index 38b78bcd0202b40fea6799490e53ab3bfdc82a10..fc2e4f80ee4aac69bd81c06bbca14e9a1c249a61 100644 (file)
@@ -11,7 +11,9 @@ do_install() {
        install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
 }
 
-inherit allarch update-rc.d
+inherit allarch update-rc.d distro_features_check
+# rdepends on weston which depends on virtual/egl
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 RDEPENDS_${PN} = "weston kbd"
 
index 342c604b98519bed2251103bda5bde1c660cbb10..95cf4956da325fa5d9bb6091854d1d0e47187cae 100644 (file)
@@ -16,7 +16,9 @@ SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
 SRC_URI[md5sum] = "24cb8a7ed0535b4fc3642643988dab36"
 SRC_URI[sha256sum] = "8963e69f328e815cec42c58046c4af721476c7541bb7d9edc71740fada5ad312"
 
-inherit autotools pkgconfig useradd
+inherit autotools pkgconfig useradd distro_features_check
+# depends on virtual/egl
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
 DEPENDS += "wayland libinput virtual/egl pango"