]> code.ossystems Code Review - openembedded-core.git/commitdiff
docbook-utils: fix build errors
authorScott Garman <scott.a.garman@intel.com>
Thu, 3 Feb 2011 00:10:33 +0000 (16:10 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Feb 2011 10:04:35 +0000 (10:04 +0000)
Fix build errors found in my first iteration of the recipe.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-devtools/docbook-utils/docbook-utils_0.6.14.bb

index 4b053b1a0fe5408b70546f73474a031b65a4e5bc..feeb23128b35b713e79c7d1db17d3c6c5a012d36 100644 (file)
@@ -17,4 +17,34 @@ SRC_URI[sha256sum] = "48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df
 
 inherit autotools
 
+do_configure_prepend_virtclass-native() {
+       # Fix hard-coded references to /etc/sgml
+       sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in
+       sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am
+       sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am
+}
+
+do_install_virtclass-native() {
+       install -d ${D}${bindir}
+       # Install the binaries and a bunch of other commonly used names for them.
+       for doctype in html ps dvi man pdf rtf tex texi txt
+       do
+               install -m 0755 ${S}/bin/docbook2$doctype ${D}${bindir}/
+               ln -sf docbook2x-$doctype ${D}${bindir}/db2$doctype
+               ln -sf docbook2$doctype ${D}${bindir}/db2$doctype
+               ln -sf docbook2$doctype ${D}${bindir}/docbook-to-$doctype
+       done
+
+       install -m 0755 ${S}/bin/jw ${D}${bindir}/
+       for i in backends/dvi backends/html backends/man \
+               backends/pdf backends/ps backends/rtf backends/tex \
+               backends/texi backends/txt frontends/docbook \
+               helpers/docbook2man-spec.pl helpers/docbook2texi-spec.pl \
+               docbook-utils.dsl
+       do
+               install -d ${D}${datadir}/sgml/docbook/utils-${PV}/`dirname $i`
+               install ${S}/$i ${D}${datadir}/sgml/docbook/utils-${PV}/$i
+       done
+}
+
 BBCLASSEXTEND = "native"