]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-devsrc: make mips devsrc files backward compatbile
authorBruce Ashfield <bruce.ashfield@gmail.com>
Sat, 9 Mar 2019 00:25:15 +0000 (19:25 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 9 Mar 2019 09:27:33 +0000 (09:27 +0000)
The additions done to devsrc to support the 5.0 kernel should have
had a graceful failure mode, since the files/directories won't be
present on older (or different) kernel versions.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/kernel-devsrc.bb

index cf2b4760510e6355acc30723b1b6057fe4543036..6daeea4f7ae4f7c9b7f6fad08f5cdaf7478851b3 100644 (file)
@@ -221,8 +221,8 @@ do_install() {
            cp -a --parents kernel/time/timeconst.bc $kerneldir/build
            cp -a --parents kernel/bounds.c $kerneldir/build
            cp -a --parents Kbuild $kerneldir/build
-           cp -a --parents arch/mips/kernel/syscalls/*.sh $kerneldir/build
-           cp -a --parents arch/mips/kernel/syscalls/*.tbl $kerneldir/build
+           cp -a --parents arch/mips/kernel/syscalls/*.sh $kerneldir/build 2>/dev/null || :
+           cp -a --parents arch/mips/kernel/syscalls/*.tbl $kerneldir/build 2>/dev/null || :
            cp -a --parents arch/mips/tools/elf-entry.c $kerneldir/build 2>/dev/null || :
        fi