]> code.ossystems Code Review - openembedded-core.git/commitdiff
libidn2: Fix charset.alias issue with musl
authorKhem Raj <raj.khem@gmail.com>
Fri, 3 Aug 2018 17:30:14 +0000 (10:30 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 8 Aug 2018 09:51:28 +0000 (10:51 +0100)
Fixes
ERROR: libidn2-2.0.5-r0 do_package: QA Issue: libidn2: Files/directories were installed but not shipped in any packag
e:
  /usr/lib/charset.alias
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or del
ete them within do_install.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/libidn/libidn2/Unset-need_charset_alias-when-building-for-musl.patch [new file with mode: 0644]
meta/recipes-extended/libidn/libidn2_2.0.5.bb

diff --git a/meta/recipes-extended/libidn/libidn2/Unset-need_charset_alias-when-building-for-musl.patch b/meta/recipes-extended/libidn/libidn2/Unset-need_charset_alias-when-building-for-musl.patch
new file mode 100644 (file)
index 0000000..ace50bb
--- /dev/null
@@ -0,0 +1,23 @@
+Unset need_charset_alias when building for musl
+
+localcharset uses ac_cv_gnu_library_2_1 from glibc21.m4
+which actually shoudl be fixed in gnulib and then all downstream
+projects will get it eventually. For now we apply the fix to
+coreutils
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Index: libidn2-2.0.5/unistring/Makefile.am
+===================================================================
+--- libidn2-2.0.5.orig/unistring/Makefile.am
++++ libidn2-2.0.5/unistring/Makefile.am
+@@ -293,7 +293,7 @@ install-exec-localcharset: all-local
+         case '$(host_os)' in \
+           darwin[56]*) \
+             need_charset_alias=true ;; \
+-          darwin* | cygwin* | mingw* | pw32* | cegcc*) \
++          darwin* | cygwin* | mingw* | pw32* | cegcc* | linux-musl*) \
+             need_charset_alias=false ;; \
+           *) \
+             need_charset_alias=true ;; \
index aaf9ecd7e78c1a0ddc46fd28197869e8aa283c3b..0d7bddbc7fea68da85706ee7ccc6e63448fd9439 100644 (file)
@@ -9,7 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ab90e75ef97cc6318ce4f2fbda62fe4d \
                     file://src/idn2.c;endline=16;md5=0283aec28e049f5bcaaeee52aa865874 \
                     file://lib/idn2.h.in;endline=27;md5=c2cd28d3f87260f157f022eabb83714f"
 
-SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz \
+           file://Unset-need_charset_alias-when-building-for-musl.patch \
+          "
 SRC_URI[md5sum] = "eaf9a5b9d03b0cce3760f34b3124eb36"
 SRC_URI[sha256sum] = "53f69170886f1fa6fa5b332439c7a77a7d22626a82ef17e2c1224858bb4ca2b8"