]> code.ossystems Code Review - openembedded-core.git/commitdiff
gtk+3: set proper FLAGS for native
authorRobert Yang <liezhi.yang@windriver.com>
Fri, 28 Mar 2014 10:03:59 +0000 (10:03 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 4 Apr 2014 10:53:15 +0000 (11:53 +0100)
The target gtk+3 does a native build in its "native" directory, we need
unset the target FLAGS for native build, otherwise, there might be build
failures.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/gtk+/gtk+3/fix-flags-for-native.patch [new file with mode: 0644]
meta/recipes-gnome/gtk+/gtk+3_3.10.7.bb

diff --git a/meta/recipes-gnome/gtk+/gtk+3/fix-flags-for-native.patch b/meta/recipes-gnome/gtk+/gtk+3/fix-flags-for-native.patch
new file mode 100644 (file)
index 0000000..9ae1088
--- /dev/null
@@ -0,0 +1,33 @@
+From 5e16904f94b5f5961f8f6e75716e6d7d228de119 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Fri, 28 Mar 2014 03:10:12 +0000
+Subject: [PATCH] gtk/native/Makefile.am: unset target FLAGS for native build
+
+The target gtk+3 does a native build in its "native" directory, we need
+unset the target FLAGS for native build, otherwise, there might be build
+failures.
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ gtk/native/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/gtk/native/Makefile.am b/gtk/native/Makefile.am
+index 64899e9..a1c814a 100644
+--- a/gtk/native/Makefile.am
++++ b/gtk/native/Makefile.am
+@@ -3,6 +3,9 @@ AM_CFLAGS = @CFLAGS_FOR_BUILD@
+ CPP = @CPP_FOR_BUILD@
+ AM_CPPFLAGS = @CPPFLAGS_FOR_BUILD@
+ AM_LDFLAGS = @LDFLAGS_FOR_BUILD@
++CFLAGS =
++CPPFLAGS =
++LDFLAGS =
+ if CROSS_COMPILING
+ if !USE_EXTERNAL_ICON_CACHE
+-- 
+1.8.3.4
+
index 9f8c6abebc972d1ff4ffd64abc46a4fc2f2724cf..d0174f60933eadfa029e5ba6125bac0e7872b5cb 100644 (file)
@@ -4,7 +4,9 @@ MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
 
 SRC_URI = "http://ftp.gnome.org/pub/gnome/sources/gtk+/${MAJ_VER}/gtk+-${PV}.tar.xz \
            file://hardcoded_libtool.patch \
-           file://fix-build-when-wayland-backend-enabled.patch"
+           file://fix-build-when-wayland-backend-enabled.patch \
+           file://fix-flags-for-native.patch \
+          "
 
 SRC_URI[md5sum] = "18a81944a8506231529a76bf2b68372b"
 SRC_URI[sha256sum] = "b7e9de15385031cff43897e7e59f6692eaabf500f36eef80e6b9d6486ad49427"