]> code.ossystems Code Review - openembedded-core.git/commitdiff
Back-port calendar fix from r420, should fix Dates (which needs to be updated)
authorChris Lord <chris@openedhand.com>
Wed, 5 Jul 2006 11:31:05 +0000 (11:31 +0000)
committerChris Lord <chris@openedhand.com>
Wed, 5 Jul 2006 11:31:05 +0000 (11:31 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@503 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/eds/eds-dbus/fix_calendar.patch [new file with mode: 0644]
openembedded/packages/eds/eds-dbus_svn.bb

diff --git a/openembedded/packages/eds/eds-dbus/fix_calendar.patch b/openembedded/packages/eds/eds-dbus/fix_calendar.patch
new file mode 100644 (file)
index 0000000..dab40a8
--- /dev/null
@@ -0,0 +1,11 @@
+--- trunk/calendar/libecal-dbus/e-cal.c.old    2006-07-05 12:23:17.000000000 +0100
++++ trunk/calendar/libecal-dbus/e-cal.c        2006-07-05 12:24:17.000000000 +0100
+@@ -2930,7 +2930,7 @@
+               E_CALENDAR_CHECK_STATUS (E_CALENDAR_STATUS_CORBA_EXCEPTION, error);
+       }
+-      if (uid)
++      if (!uid)
+               E_CALENDAR_CHECK_STATUS (E_CALENDAR_STATUS_OTHER_ERROR, error);
+       else
+               E_CALENDAR_CHECK_STATUS (E_CALENDAR_STATUS_OK, error);
index 71c5aedb1da178d19ed22f36605d47625ac3d2b6..a6757ccd42799f43162ff0a2ce890416de9b6084 100755 (executable)
@@ -4,13 +4,14 @@ RDEPENDS = "gconf"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Evolution database backend server"
 PV = "1.4.0+svn${SRCDATE}"
-PR = "r16"
+PR = "r17"
 
 SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
            file://no_libdb.patch;patch=1 \
            file://no_iconv_test.patch;patch=1 \
            file://no_libedataserverui.patch;patch=1 \
            file://disable_orbit.patch;patch=1;maxdate=20060126 \
+          file://fix_calendar.patch;patch=1;maxdate=20060619 \
            file://iconv-detect.h"
 
 S = "${WORKDIR}/trunk"