]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssh: fix sshd_config_readonly creation
authorJonathan Liu <net147@gmail.com>
Thu, 10 Apr 2014 08:24:48 +0000 (18:24 +1000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 10 Apr 2014 09:22:25 +0000 (10:22 +0100)
The readonly sshd config sshd_config_readonly needs to be created from
the installed sshd_config as make install will adjust the paths in
the config file. This fixes the path for sftp-server being correct
in sshd_config but incorrect in sshd_config_readonly.

Signed-off-by: Jonathan Liu <net147@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/openssh/openssh_6.5p1.bb

index 3496b4d878242b1f51ffac2652fdb5228106b61e..2c4da709880cdb52f5b8e7a27df61f5443dae223 100644 (file)
@@ -99,7 +99,7 @@ do_install_append () {
 
         # Create config files for read-only rootfs
        install -d ${D}${sysconfdir}/ssh
-       install -m 644 ${WORKDIR}/sshd_config ${D}${sysconfdir}/ssh/sshd_config_readonly
+       install -m 644 ${D}${sysconfdir}/ssh/sshd_config ${D}${sysconfdir}/ssh/sshd_config_readonly
        sed -i '/HostKey/d' ${D}${sysconfdir}/ssh/sshd_config_readonly
        echo "HostKey /var/run/ssh/ssh_host_rsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
        echo "HostKey /var/run/ssh/ssh_host_dsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly