]> code.ossystems Code Review - openembedded-core.git/commitdiff
tzcode-native: Set cc to ${CC}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 9 Mar 2017 09:48:44 +0000 (09:48 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 10 Mar 2017 14:49:48 +0000 (14:49 +0000)
Building on a system without "cc" showed this recipe doesn't respect
the $CC variable. Fix this by passing the right option to the makefile.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/tzcode/tzcode-native_2017a.bb

index 0daac531fd2adf222f70a42a9bea1b26a48ccdf0..2c26744f33af80d35cc2fe336a3a31779a212f23 100644 (file)
@@ -18,6 +18,8 @@ S = "${WORKDIR}"
 
 inherit native
 
+EXTRA_OEMAKE += "cc=${CC}"
+
 do_install () {
         install -d ${D}${bindir}/
         install -m 755 zic ${D}${bindir}/