]> code.ossystems Code Review - openembedded-core.git/commitdiff
ofono: conditionally enable bluetooth
authorAnders Darander <anders@chargestorm.se>
Wed, 17 Aug 2011 06:41:28 +0000 (08:41 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 17 Aug 2011 14:18:01 +0000 (15:18 +0100)
Use DISTRO_FEATURE to conditionally depend on bluez4, as well as enabling bluetooth.

Signed-off-by: Anders Darander <anders@chargestorm.se>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/ofono/ofono.inc
meta/recipes-connectivity/ofono/ofono_0.50.bb
meta/recipes-connectivity/ofono/ofono_git.bb

index a14b35a84717f028e2fab2b118f56d189a7e162d..0b1a6e12345292aaa55ed94aae33ffc365be60c3 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
 
 inherit autotools pkgconfig update-rc.d
 
-DEPENDS  = "dbus glib-2.0 udev bluez4"
+DEPENDS  = "dbus glib-2.0 udev ${@base_contains('DISTRO_FEATURES', 'bluetooth','bluez4', '', d)}"
 
 INITSCRIPT_NAME = "ofono"
 INITSCRIPT_PARAMS = "defaults 22"
index ef4fbf0ba88affd891c85b0a380b38ee08b6ca89..b679200fb0c28d89b2b869d2208e68e8f891239a 100644 (file)
@@ -7,6 +7,7 @@ SRC_URI  = "${KERNELORG_MIRROR}/linux/network/ofono/${BPN}-${PV}.tar.bz2 \
 
 EXTRA_OECONF += "\
     --enable-test \
+    ${@base_contains('DISTRO_FEATURES', 'bluetooth','--enable-bluetooth', '--disable-bluetooth', d)} \
 "
 
 SRC_URI[md5sum] = "b2656fd0bbf33f926fc86c1e8915d697"
index dbad5a1b68a3eb3143f7899ee8d4fb642946d7c6..f1770c2d128c58d2fe309eb97c258b8b34e475e9 100644 (file)
@@ -10,6 +10,10 @@ PR = "r1"
 SRC_URI  = "git://git.kernel.org/pub/scm/network/ofono/ofono.git;protocol=git \
            file://ofono"
 
+EXTRA_OECONF += "\
+    ${@base_contains('DISTRO_FEATURES', 'bluetooth','--enable-bluetooth', '--disable-bluetooth', d)} \
+"
+
 do_configure_prepend () {
   ${S}/bootstrap
 }