]> code.ossystems Code Review - openembedded-core.git/commitdiff
insane.bbclass: allow reporting all md5 mismatch warnings
authorKevin Tian <kevin.tian@intel.com>
Mon, 28 Jun 2010 03:02:45 +0000 (11:02 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 30 Jun 2010 12:19:05 +0000 (13:19 +0100)
instead of exiting when once one md5 mismatch is seen. This would be
helpful to save time on filling md5sum for multiple license check
files.

Signed-off-by Kevin Tian <kevin.tian@intel.com>

meta/classes/insane.bbclass

index 0511717c94ecebf4a6682931e513dcaba8f1fdab..230a1be7524c8d83af83a5b991a271ddae02e963 100644 (file)
@@ -326,7 +326,7 @@ def package_qa_check_license(workdir, d):
             bb.error ("md5 data is not matching for ", url)
             bb.note ("The new md5 checksum is ", md5chksum)
             bb.note ("Check if the license information has changed, and if it has update the .bb file with correct license")
-            return False
+            sane = False
 
     return sane