]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot: package up u-boot.bin for field upgrades
authorKoen Kooi <koen@dominion.thruhere.net>
Mon, 30 May 2011 12:01:49 +0000 (14:01 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 Jun 2011 13:47:25 +0000 (14:47 +0100)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
meta/recipes-bsp/uboot/u-boot.inc
meta/recipes-bsp/uboot/u-boot_2011.03.bb

index 83dfb6fa862f8228f90b9c3de3f44d27aca49876..2be9fc9ebe6a0357e688a4050136087ca39460a9 100644 (file)
@@ -21,6 +21,7 @@ python () {
 }
 
 UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
+UBOOT_BINARY ?= "u-boot.bin"
 UBOOT_SYMLINK ?= "u-boot-${MACHINE}.bin"
 UBOOT_MAKE_TARGET ?= "all"
 
@@ -32,6 +33,16 @@ do_compile () {
        oe_runmake ${UBOOT_MAKE_TARGET}
 }
 
+do_install () {
+    install -d ${D}/boot
+    install ${S}/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
+    ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
+}
+
+FILES_${PN} = "/boot"
+# no gnu_hash in uboot.bin, by design, so skip QA
+INSANE_SKIP_${PN} = True
+
 do_deploy () {
        install ${S}/u-boot.bin ${DEPLOYDIR}/${UBOOT_IMAGE}
 
index 0fbb9ba1880349bbdf85d2704edb13db3d55971d..07f0609194ea429b362c3b4b6bc0ed33f85a32a9 100644 (file)
@@ -14,7 +14,7 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-git/${MACHINE
 
 SRCREV = "v2011.03"
 PV = "v2011.03+git${SRCPV}"
-PR="r3"
+PR="r4"
 
 SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"