]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: Add util-linux-fsck to RDEPENDS
authorAlex Kiernan <alex.kiernan@gmail.com>
Mon, 17 Sep 2018 17:31:36 +0000 (17:31 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 21 Sep 2018 15:15:19 +0000 (08:15 -0700)
systemd-fsck expects util-linux-fsck passing a number of options that
busybox fsck doesn't interpret. It then continues silently when run, so
disks end up not having fsck run at all.

Move util-linux-fsck from RRECOMMENDS to RDEPENDS to ensure we have the
fsck which systemd expects.

Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_239.bb

index 55e398693568ae566f5b72082607fdbcaeebf539..194efb5b9467b7bedae179dd410cc3317d64399f 100644 (file)
@@ -502,13 +502,13 @@ FILES_${PN} = " ${base_bindir}/* \
 
 FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ ${sysconfdir}/rpm/macros.systemd"
 
-RDEPENDS_${PN} += "kmod dbus util-linux-mount udev (= ${EXTENDPKGV}) util-linux-agetty"
+RDEPENDS_${PN} += "kmod dbus util-linux-mount udev (= ${EXTENDPKGV}) util-linux-agetty util-linux-fsck"
 RDEPENDS_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'serial-getty-generator', '', 'systemd-serialgetty', d)}"
 RDEPENDS_${PN} += "volatile-binds update-rc.d"
 
 RRECOMMENDS_${PN} += "systemd-extra-utils \
                       systemd-compat-units udev-hwdb \
-                      util-linux-fsck e2fsprogs-e2fsck \
+                      e2fsprogs-e2fsck \
                       kernel-module-autofs4 kernel-module-unix kernel-module-ipv6 \
                       os-release \
 "