]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit-inittab: remove specific handling of SERIAL_CONSOLE
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Tue, 30 Apr 2013 14:31:00 +0000 (15:31 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 May 2013 16:40:51 +0000 (17:40 +0100)
We already handle SERIAL_CONSOLES here and this is now set from
SERIAL_CONSOLE if not already set.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb

index fbac8937fead682ffc5bde89e4f3a41b7761cab7..23c284d131c3705ead84ebb238f7d1297974de63 100644 (file)
@@ -17,9 +17,6 @@ do_compile() {
 do_install() {
        install -d ${D}${sysconfdir}
     install -m 0644 ${WORKDIR}/inittab ${D}${sysconfdir}/inittab
-    if [ ! -z "${SERIAL_CONSOLE}" ]; then
-        echo "S:2345:respawn:${base_sbindir}/getty ${SERIAL_CONSOLE}" >> ${D}${sysconfdir}/inittab
-    fi
 
     tmp="${SERIAL_CONSOLES}"
     for i in $tmp
@@ -71,7 +68,7 @@ else
 fi
 }
 
-# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
+# USE_VT and SERIAL_CONSOLES are generally defined by the MACHINE .conf.
 # Set PACKAGE_ARCH appropriately.
 PACKAGE_ARCH = "${MACHINE_ARCH}"