]> code.ossystems Code Review - openembedded-core.git/commitdiff
networkmanager: Update to work with recent libnl
authorRichard Purdie <rpurdie@linux.intel.com>
Sat, 16 May 2009 11:46:45 +0000 (12:46 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Sat, 16 May 2009 11:46:45 +0000 (12:46 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/networkmanager/files/libnlfix.patch [new file with mode: 0644]
meta/packages/networkmanager/networkmanager_svn.bb

diff --git a/meta/packages/networkmanager/files/libnlfix.patch b/meta/packages/networkmanager/files/libnlfix.patch
new file mode 100644 (file)
index 0000000..69f4922
--- /dev/null
@@ -0,0 +1,29 @@
+Index: trunk/src/nm-netlink.c
+===================================================================
+--- trunk.orig/src/nm-netlink.c        2007-09-25 22:37:50.000000000 +0100
++++ trunk/src/nm-netlink.c     2009-05-16 12:44:26.000000000 +0100
+@@ -52,16 +52,20 @@
+ struct nl_handle *
+ nm_netlink_get_default_handle (void)
+ {
++      struct nl_cb *cb;
++
+       if (def_nl_handle)
+               return def_nl_handle;
+-      def_nl_handle = nl_handle_alloc_nondefault (NL_CB_VERBOSE);
+-      g_assert (def_nl_handle);
++      cb = nl_cb_alloc(NL_CB_VERBOSE);
++      def_nl_handle = nl_handle_alloc_cb (cb);
++      if (!def_nl_handle) {
++              nm_warning ("couldn't allocate netlink handle.");
++              return NULL;
++      }
+-      nl_handle_set_pid (def_nl_handle, (pthread_self () << 16 | getpid ()));
+       if (nl_connect (def_nl_handle, NETLINK_ROUTE) < 0) {
+               nm_error ("couldn't connect to netlink: %s", nl_geterror ());
+-              nl_handle_destroy (def_nl_handle);
+               return NULL;
+       }
index 96d1cf39807bb03536ca8989eae1613f9dffda42..d3c5443335601d9e7c555b574b66b2718bf78a5e 100644 (file)
@@ -7,10 +7,11 @@ DEPENDS = "libnl dbus dbus-glib hal gconf-dbus wireless-tools ppp gnome-common p
 RDEPENDS = "hal wpa-supplicant iproute2 dhcp-client"
 
 PV = "0.7+svnr${SRCREV}"
-PR = "r8"
+PR = "r9"
 
 SRC_URI="svn://svn.gnome.org/svn/NetworkManager/;module=trunk;proto=http \
        file://no-restarts.diff;patch=1;pnum=0 \
+       file://libnlfix.patch;patch=1 \
         file://makefile-fix.patch;patch=1 \
        file://allow-disabling.patch;patch=1 \
        file://NetworkManager \