]> code.ossystems Code Review - openembedded-core.git/commitdiff
gtk+: Fix build of documentation
authorScott Garman <scott.a.garman@intel.com>
Thu, 17 Feb 2011 21:35:05 +0000 (13:35 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 18 Feb 2011 01:16:26 +0000 (01:16 +0000)
This resolves the following error messages when building gtk+
documentation:

mv: cannot stat `gtk-faq': No such file or directory
mv: cannot stat `gtk-tut': No such file or directory

Fixes [BUGID #730]

Also adds docbook-utils-native to DEPENDS so we don't rely on
host documentation building tools.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-gnome/gtk+/gtk+-2.22.1/doc-fixes.patch [new file with mode: 0644]
meta/recipes-gnome/gtk+/gtk+.inc
meta/recipes-gnome/gtk+/gtk+_2.12.7.bb
meta/recipes-gnome/gtk+/gtk+_2.16.6.bb
meta/recipes-gnome/gtk+/gtk+_2.22.1.bb

diff --git a/meta/recipes-gnome/gtk+/gtk+-2.22.1/doc-fixes.patch b/meta/recipes-gnome/gtk+/gtk+-2.22.1/doc-fixes.patch
new file mode 100644 (file)
index 0000000..67fd29a
--- /dev/null
@@ -0,0 +1,33 @@
+This fixes the following build errors with the gtk+ faq and tutorial
+documentation:
+
+mv: cannot stat `gtk-faq': No such file or directory
+mv: cannot stat `gtk-tut': No such file or directory
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+diff -urN gtk+-2.22.1.orig//docs/faq/Makefile.am gtk+-2.22.1/docs/faq/Makefile.am
+--- gtk+-2.22.1.orig//docs/faq/Makefile.am     2010-11-15 04:13:09.000000000 -0800
++++ gtk+-2.22.1/docs/faq/Makefile.am   2011-02-17 13:16:30.603214103 -0800
+@@ -9,7 +9,8 @@
+         (cd $(srcdir); \
+          db2html gtk-faq.sgml; \
+          test -d html && rm -r html; \
+-         mv gtk-faq html); \
++         mkdir html; \
++         mv *.html html); \
+       fi
+ pdf:
+diff -urN gtk+-2.22.1.orig//docs/tutorial/Makefile.am gtk+-2.22.1/docs/tutorial/Makefile.am
+--- gtk+-2.22.1.orig//docs/tutorial/Makefile.am        2010-11-15 04:13:09.000000000 -0800
++++ gtk+-2.22.1/docs/tutorial/Makefile.am      2011-02-17 13:15:40.110369180 -0800
+@@ -42,7 +42,8 @@
+         (cd $(srcdir); \
+          db2html gtk-tut.sgml; \
+          test -d html && rm -r html; \
+-         mv gtk-tut html; \
++         mkdir html; \
++         mv *.html html; \
+          mkdir html/images; \
+          cp images/*.png html/images); \
+       fi
index 94a8fe618d2a9392808205b013b3c19269d754f7..853c05946dd48938d0adbf53cca0d69af7c119b5 100644 (file)
@@ -10,8 +10,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
 
 SECTION = "libs"
 PRIORITY = "optional"
-DEPENDS = "glib-2.0 pango atk jpeg libpng libxext libxcursor gtk-doc-native libxrandr \
-           libgcrypt libxdamage libxrender libxcomposite cairo gdk-pixbuf"
+DEPENDS = "glib-2.0 pango atk jpeg libpng libxext libxcursor \
+           gtk-doc-native docbook-utils-native libxrandr libgcrypt \
+           libxdamage libxrender libxcomposite cairo gdk-pixbuf"
 
 inherit autotools pkgconfig
 
index 12193f9b979bab6ed92e6d3b60869bc8b9c38004..7f242d94dfafabaa88f38ef8f9cb548b68603a3b 100644 (file)
@@ -1,6 +1,6 @@
 require gtk+.inc
 
-PR = "r10"
+PR = "r11"
 
 SRC_URI = "http://download.gnome.org/sources/gtk+/2.12/gtk+-${PV}.tar.bz2 \
            file://xsettings.patch;patch=1 \
index 1864d1ba060059efd0aa2d1c4d132279b2bccfcb..5060829e4b112df2c0ea5ceddde11c5f4dbf4cc2 100644 (file)
@@ -1,6 +1,6 @@
 require gtk+.inc
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://download.gnome.org/sources/gtk+/2.16/gtk+-${PV}.tar.bz2 \
            file://xsettings.patch;patch=1 \
index 35aa88325168c32b890c29c4c18030d6a8fc861a..e311a8cc4485f1b5110aa3a4fbb7c4b59067b985 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
                     file://gtk/gtk.h;endline=27;md5=c59e0b4490dd135a5726ebf851f9b17f \
                     file://gdk/gdk.h;endline=27;md5=07db285ec208fb3e0bf7d861b0614202 \
                     file://tests/testgtk.c;endline=27;md5=262db5db5f776f9863e56df31423e24c"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://download.gnome.org/sources/gtk+/2.22/gtk+-${PV}.tar.bz2 \
            file://xsettings.patch;patch=1 \
@@ -13,7 +13,8 @@ SRC_URI = "http://download.gnome.org/sources/gtk+/2.22/gtk+-${PV}.tar.bz2 \
            file://no-demos.patch;patch=1 \
            file://cellrenderer-cairo.patch;patch=1;pnum=0 \
            file://toggle-font.diff;patch=1;pnum=0 \
-          file://0001-bgo-584832-Duplicate-the-exec-string-returned-by-gtk.patch;patch=1 \
+           file://0001-bgo-584832-Duplicate-the-exec-string-returned-by-gtk.patch;patch=1 \
+           file://doc-fixes.patch \
 # TO MERGE
 #           file://entry-cairo.patch;patch=1;pnum=0 \
 #           file://filesystem-volumes.patch;patch=1 \