]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: add perf.inc
authorTom Zanussi <tom.zanussi@intel.com>
Mon, 9 Jul 2012 17:07:09 +0000 (12:07 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 Jul 2012 19:25:24 +0000 (20:25 +0100)
Add a perf.inc to contain utility functions and definitions and to
avoid cluttering up the main recipe.

Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.inc [new file with mode: 0644]
meta/recipes-kernel/perf/perf_3.4.bb

diff --git a/meta/recipes-kernel/perf/perf.inc b/meta/recipes-kernel/perf/perf.inc
new file mode 100644 (file)
index 0000000..d112751
--- /dev/null
@@ -0,0 +1,22 @@
+PERF_FEATURES_ENABLE ?= "perf-scripting perf-tui"
+
+def perf_feature_enabled(feature, trueval, falseval, d):
+    """
+    Check which perf features are enabled.
+
+    The PERF_FEATURES_ENABLE variable lists the perf features to
+    enable.  Override it if you want something different from what's
+    listed above, which is the default.  If empty, the build won't
+    enable any features (which may be exactly what you want, just a
+    barebones perf without any extra baggage, what you get if you
+    specify an empty feature list).
+
+    Available perf features:
+      perf-scripting: enable support for Perl and Python bindings
+      perf-tui: enable support for the perf TUI (via libnewt)
+
+    """
+    enabled_features = d.getVar("PERF_FEATURES_ENABLE", True) or ""
+    if feature in enabled_features:
+               return trueval
+    return falseval
index 381332e7b74a18a1ef5306732136f67042fe6d7a..d49424309d0268eb3920340eb4f06ad042ebacc7 100644 (file)
@@ -11,6 +11,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
 
 PR = "r1"
 
+require perf.inc
+
 BUILDPERF_libc-uclibc = "no"
 
 DEPENDS = "virtual/kernel \