]> code.ossystems Code Review - openembedded-core.git/commitdiff
buildtools-tarball: add wic dependency into extended buildtools
authorChangqing Li <changqing.li@windriver.com>
Wed, 25 Nov 2020 02:02:48 +0000 (10:02 +0800)
committerAnuj Mittal <anuj.mittal@intel.com>
Thu, 10 Dec 2020 00:33:27 +0000 (08:33 +0800)
fix below error:
wic ls ./core-image-minimal-intel-x86-64.wic

ERROR: Can't find executable parted

wic depend on some tools like parted/mtools/..., and we have those
tools in native_sysroot. so above problem can be avoided by
run command like wic ls imagename.wic --native-sysroot <path>

but this cannot cover condition that usr don't have build the
image, the image just copy from somewhere.

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit c0eda6ec09395f3a04cb80107a3ca33a063b21f8)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-core/meta/buildtools-extended-tarball.bb

index c32d0107c3862e26e54d92575de713c76cd81f9e..08164867548a618947d8f1e1f10bb65be3aa5284 100644 (file)
@@ -29,6 +29,9 @@ TOOLCHAIN_HOST_TASK += "\
     nativesdk-pkgconfig \
     nativesdk-glibc-utils \
     nativesdk-libxcrypt-dev \
+    nativesdk-parted \
+    nativesdk-dosfstools \
+    nativesdk-gptfdisk \
     "
 
 TOOLCHAIN_OUTPUTNAME = "${SDK_ARCH}-buildtools-extended-nativesdk-standalone-${DISTRO_VERSION}"