]> code.ossystems Code Review - openembedded-core.git/commitdiff
tcl: Fix the location of the installed headers
authorMark Hatle <mark.hatle@windriver.com>
Sat, 23 Mar 2013 16:14:17 +0000 (11:14 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 23 Mar 2013 18:09:54 +0000 (18:09 +0000)
Having '${S}' in the for loop was causing the headers to be installed
into the wrong location.  Move the 'S' to the install line.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/tcltk/tcl_8.5.13.bb

index 01fe36dc97261ca19993980f27f18d597832de30..be9c61bf34f70357d56d89a39f4d2cf95509cf7f 100644 (file)
@@ -52,10 +52,10 @@ do_install() {
        install -d ${D}${bindir_crossscripts}
        install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
        cd ..
-       for dir in ${S}/../compat ${S}/../generic ${S}/../unix
+       for dir in compat generic unix
        do
                install -d ${D}${includedir}/tcl${PV}/$dir
-               install -m 0644 $dir/*.h ${D}${includedir}/tcl${PV}/$dir/
+               install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/tcl${PV}/$dir/
        done
 }