]> code.ossystems Code Review - openembedded-core.git/commitdiff
gmp: upgrade from 4.2.4 to 5.0.1
authorNitin A Kamble <nitin.a.kamble@intel.com>
Mon, 12 Jul 2010 07:18:43 +0000 (00:18 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 16 Jul 2010 15:25:16 +0000 (16:25 +0100)
Change SECTION to devel
Rebased the configure patch to the newer code.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/packages/gmp/gmp.inc
meta/packages/gmp/gmp/amd64.patch [moved from meta/packages/gmp/gmp-4.2.4/amd64.patch with 100% similarity]
meta/packages/gmp/gmp/configure.patch [moved from meta/packages/gmp/gmp-4.2.4/configure.patch with 80% similarity]
meta/packages/gmp/gmp/sh4-asmfix.patch [moved from meta/packages/gmp/gmp-4.2.4/sh4-asmfix.patch with 100% similarity]
meta/packages/gmp/gmp/use-includedir.patch [moved from meta/packages/gmp/gmp-4.2.4/use-includedir.patch with 100% similarity]
meta/packages/gmp/gmp_4.2.4.bb [deleted file]
meta/packages/gmp/gmp_5.0.1.bb [new file with mode: 0644]

index 6023910308a681e559ba88952603d460326b94e7..6b56f7e7c8ff92d48f01a43b4f3fb831b6cede41 100644 (file)
@@ -1,14 +1,16 @@
-SECTION = "libs"
+SECTION = "devel"
 DESCRIPTION = "GNU multiprecision arithmetic library"
 HOMEPAGE = "http://www.swox.com/gmp/"
-LICENSE = "GPL LGPL"
+LICENSE = "GPLv3 LGPLv3"
 
 SRC_URI = "ftp://ftp.gnu.org/gnu/gmp/gmp-${PV}.tar.bz2 \
-          file://configure.patch;patch=1 \
-          file://amd64.patch;patch=1"
+          file://configure.patch \
+          file://amd64.patch "
 
 inherit autotools
 
 ARM_INSTRUCTION_SET = "arm"
 
 acpaths = ""
+
+BBCLASSEXTEND = "native nativesdk"
similarity index 80%
rename from meta/packages/gmp/gmp-4.2.4/configure.patch
rename to meta/packages/gmp/gmp/configure.patch
index 8056953230871e60c852c6066ebb28eb7a42e6b3..ed0c02d86c28fdbc615887bbc59eaacf87a95b32 100644 (file)
@@ -2,11 +2,11 @@
  configure.in |   24 +++++++++---------------
  2 files changed, 23 insertions(+), 27 deletions(-)
 
-Index: gmp-4.2.4/acinclude.m4
+Index: gmp-5.0.1/acinclude.m4
 ===================================================================
---- gmp-4.2.4.orig/acinclude.m4        2008-09-05 14:21:12.000000000 +0200
-+++ gmp-4.2.4/acinclude.m4     2008-10-15 23:37:38.062976613 +0200
-@@ -30,20 +30,20 @@
+--- gmp-5.0.1.orig/acinclude.m4
++++ gmp-5.0.1/acinclude.m4
+@@ -30,20 +30,20 @@ dnl    a_out.exe - OpenVMS DEC C called 
  dnl    conftest.exe - various DOS compilers
  
  
@@ -28,10 +28,10 @@ Index: gmp-4.2.4/acinclude.m4
  
 -define(X86_PATTERN,
 +define([X86_PATTERN],
- [[i?86*-*-* | k[5-8]*-*-* | pentium*-*-* | athlon-*-* | viac3*-*-* | geode*-*-*]])
+ [[i?86*-*-* | k[5-8]*-*-* | pentium*-*-* | athlon-*-* | viac3*-*-* | geode*-*-* | atom-*-*]])
  
-@@ -62,7 +62,7 @@
+ define(X86_64_PATTERN,
+@@ -64,7 +64,7 @@ dnl      x86         ->  x86
  dnl      x86/k6      ->  k6
  dnl      x86/k6/mmx  ->  k6_mmx
  
@@ -40,8 +40,8 @@ Index: gmp-4.2.4/acinclude.m4
  [[$1=`echo $2 | sed -e '/\//s:^[^/]*/::' -e 's:[\\/]:_:g'`]])
  
  
-@@ -71,7 +71,7 @@
- dnl  Emit code to remove any occurance of ITEM from $LISTVAR.  ITEM can be a
+@@ -73,7 +73,7 @@ dnl  ----------------------------------
+ dnl  Emit code to remove any occurrence of ITEM from $LISTVAR.  ITEM can be a
  dnl  shell expression like $foo if desired.
  
 -define(GMP_REMOVE_FROM_LIST,
@@ -49,7 +49,7 @@ Index: gmp-4.2.4/acinclude.m4
  [remove_from_list_tmp=
  for remove_from_list_i in $[][$1]; do
    if test $remove_from_list_i = [$2]; then :;
-@@ -87,12 +87,12 @@
+@@ -89,12 +89,12 @@ dnl  GMP_STRIP_PATH(subdir)
  dnl  ----------------------
  dnl  Strip entries */subdir from $path and $fat_path.
  
@@ -64,16 +64,16 @@ Index: gmp-4.2.4/acinclude.m4
  [tmp_path=
  for i in $[][$1]; do
    case $i in
-@@ -113,7 +113,7 @@
- dnl  Dummy values for __GMP_BITS_PER_MP_LIMB and GMP_LIMB_BITS are enough
+@@ -115,7 +115,7 @@ dnl
+ dnl  Dummy value for GMP_LIMB_BITS is enough
  dnl  for all current configure-time uses of gmp.h.
  
 -define(GMP_INCLUDE_GMP_H,
 +define([GMP_INCLUDE_GMP_H],
  [[#define __GMP_WITHIN_CONFIGURE 1   /* ignore template stuff */
  #define GMP_NAIL_BITS $GMP_NAIL_BITS
- #define __GMP_BITS_PER_MP_LIMB 123 /* dummy for GMP_NUMB_BITS etc */
-@@ -129,7 +129,7 @@
+ #define GMP_LIMB_BITS 123
+@@ -130,7 +130,7 @@ dnl  Expand at autoconf time to the valu
  dnl  FILE.  The regexps here aren't very rugged, but are enough for gmp.
  dnl  /dev/null as a parameter prevents a hang if $2 is accidentally omitted.
  
@@ -82,7 +82,7 @@ Index: gmp-4.2.4/acinclude.m4
  [patsubst(patsubst(
  esyscmd([grep "^#define $1 " $2 /dev/null 2>/dev/null]),
  [^.*$1[       ]+],[]),
-@@ -143,7 +143,7 @@
+@@ -144,7 +144,7 @@ dnl  The gmp version number, extracted f
  dnl  autoconf time.  Two digits like 3.0 if patchlevel <= 0, or three digits
  dnl  like 3.0.1 if patchlevel > 0.
  
@@ -90,8 +90,8 @@ Index: gmp-4.2.4/acinclude.m4
 +define([GMP_VERSION],
  [GMP_HEADER_GETVAL(__GNU_MP_VERSION,gmp-h.in)[]dnl
  .GMP_HEADER_GETVAL(__GNU_MP_VERSION_MINOR,gmp-h.in)[]dnl
- ifelse(m4_eval(GMP_HEADER_GETVAL(__GNU_MP_VERSION_PATCHLEVEL,gmp-h.in) > 0),1,
-@@ -1506,7 +1506,9 @@
+ .GMP_HEADER_GETVAL(__GNU_MP_VERSION_PATCHLEVEL,gmp-h.in)])
+@@ -1506,7 +1506,9 @@ esac
  echo ["define(<CONFIG_TOP_SRCDIR>,<\`$tmp'>)"] >>$gmp_tmpconfigm4
  
  # All CPUs use asm-defs.m4
@@ -102,13 +102,13 @@ Index: gmp-4.2.4/acinclude.m4
  ])
  
  
-Index: gmp-4.2.4/configure.in
+Index: gmp-5.0.1/configure.in
 ===================================================================
---- gmp-4.2.4.orig/configure.in        2008-08-01 19:24:04.000000000 +0200
-+++ gmp-4.2.4/configure.in     2008-10-15 23:35:03.466325346 +0200
-@@ -29,12 +29,6 @@
+--- gmp-5.0.1.orig/configure.in
++++ gmp-5.0.1/configure.in
+@@ -29,12 +29,6 @@ AC_REVISION($Revision$)
  AC_PREREQ(2.59)
- AC_INIT(GNU MP, GMP_VERSION, gmp-bugs@swox.com, gmp)
+ AC_INIT(GNU MP, GMP_VERSION, gmp-bugs@gmplib.org, gmp)
  AC_CONFIG_SRCDIR(gmp-impl.h)
 -m4_pattern_forbid([^[ \t]*GMP_])
 -m4_pattern_allow(GMP_LDFLAGS)
@@ -119,7 +119,7 @@ Index: gmp-4.2.4/configure.in
  
  # If --target is not used then $target_alias is empty, but if say
  # "./configure athlon-pc-freebsd3.5" is used, then all three of
-@@ -278,7 +272,7 @@
+@@ -303,7 +297,7 @@ AH_VERBATIM([HAVE_HOST_CPU_1],
  # After GMP specific searches and tests, the standard autoconf AC_PROG_CC is
  # called.  User selections of CC etc are respected.
  #
@@ -128,7 +128,7 @@ Index: gmp-4.2.4/configure.in
  # pre-testing, since they of course depend on AC_PROG_CC, and also some of
  # them cache their results, which is not wanted.
  #
-@@ -370,7 +364,7 @@
+@@ -395,7 +389,7 @@ abilist="standard"
  # FIXME: We'd like to prefer an ANSI compiler, perhaps by preferring
  # c89 over cc here.  But note that on HP-UX c89 provides a castrated
  # environment, and would want to be excluded somehow.  Maybe
@@ -137,7 +137,7 @@ Index: gmp-4.2.4/configure.in
  # we don't need to worry.
  #
  cclist="gcc cc"
-@@ -1525,7 +1519,7 @@
+@@ -1580,7 +1574,7 @@ esac
  CFLAGS_or_unset=${CFLAGS-'(unset)'}
  CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'}
  
@@ -146,7 +146,7 @@ Index: gmp-4.2.4/configure.in
  User:
  ABI=$ABI
  CC=$CC
-@@ -1896,7 +1890,6 @@
+@@ -1987,7 +1981,6 @@ AC_SUBST(DEFN_LONG_LONG_LIMB)
  
  # The C compiler and preprocessor, put into ANSI mode if possible.
  AC_PROG_CC
@@ -154,7 +154,7 @@ Index: gmp-4.2.4/configure.in
  AC_PROG_CPP
  GMP_H_ANSI
  
-@@ -1919,11 +1912,11 @@
+@@ -2010,11 +2003,11 @@ AC_SUBST(CCAS)
  
  # The C++ compiler, if desired.
  want_cxx=no
@@ -168,7 +168,7 @@ Index: gmp-4.2.4/configure.in
    cxxflags_ac_prog_cxx=$CXXFLAGS
    cxxflags_list=ac_prog_cxx
  
-@@ -2029,7 +2022,7 @@
+@@ -2120,7 +2113,7 @@ case $host in
  esac
  
  
@@ -177,7 +177,7 @@ Index: gmp-4.2.4/configure.in
  Decided:
  ABI=$ABI
  CC=$CC
-@@ -3208,7 +3201,7 @@
+@@ -3376,7 +3369,7 @@ GMP_FINISH
  # FIXME: Upcoming version of autoconf/automake may not like broken lines.
  #        Right now automake isn't accepting the new AC_CONFIG_FILES scheme.
  
@@ -186,7 +186,7 @@ Index: gmp-4.2.4/configure.in
    mpbsd/Makefile mpf/Makefile mpn/Makefile mpq/Makefile                       \
    mpz/Makefile printf/Makefile scanf/Makefile cxx/Makefile            \
    tests/Makefile tests/devel/Makefile tests/mpbsd/Makefile            \
-@@ -3217,4 +3210,5 @@
+@@ -3385,4 +3378,5 @@ AC_OUTPUT(Makefile                                                       \
    tests/cxx/Makefile                                                  \
    doc/Makefile tune/Makefile                                          \
    demos/Makefile demos/calc/Makefile demos/expr/Makefile              \
diff --git a/meta/packages/gmp/gmp_4.2.4.bb b/meta/packages/gmp/gmp_4.2.4.bb
deleted file mode 100644 (file)
index 5c1bdc9..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-PR = "r0"
-
-SRC_URI_append += "file://sh4-asmfix.patch;patch=1 \
-                   file://use-includedir.patch;patch=1 \
-                 "
-require gmp.inc
-LICENSE = "GPLv3 LGPLv3"
-
-BBCLASSEXTEND = "native nativesdk"
\ No newline at end of file
diff --git a/meta/packages/gmp/gmp_5.0.1.bb b/meta/packages/gmp/gmp_5.0.1.bb
new file mode 100644 (file)
index 0000000..dd908bd
--- /dev/null
@@ -0,0 +1,7 @@
+require gmp.inc
+
+PR = "r0"
+
+SRC_URI_append += "file://sh4-asmfix.patch \
+                   file://use-includedir.patch "
+