]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: Tweak checkroot to work with recent versions of busybox
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 2 Jun 2010 10:45:59 +0000 (11:45 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 2 Jun 2010 10:45:59 +0000 (11:45 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/initscripts/initscripts-1.0/checkroot.sh
meta/packages/initscripts/initscripts_1.0.bb

index 8226f543dd1218a80bebe57208d4cc40568ef1b8..02697ce9bf299bbc245f69aaea17c720d23ab54b 100755 (executable)
@@ -18,13 +18,13 @@ test "$SULOGIN" = yes && sulogin -t 30 $CONSOLE
 #
 # Read /etc/fstab.
 #
-exec 9>&0 </etc/fstab
+exec 9/etc/fstab
 rootmode=rw
 rootopts=rw
 rootcheck=no
 swap_on_md=no
 devfs=
-while read fs mnt type opts dump pass junk
+while read fs mnt type opts dump pass junk <&9
 do
        case "$fs" in
                ""|\#*)
index 08a0f7806f2490c9a6e92a0fc53e7e9dbc186836..129786a7e901b0b23c7cb4be212f8d23040fbf99 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "required"
 DEPENDS = "makedevs"
 RDEPENDS = "makedevs"
 LICENSE = "GPL"
-PR = "r120"
+PR = "r121"
 
 SRC_URI = "file://functions \
            file://halt \