]> code.ossystems Code Review - openembedded-core.git/commitdiff
nfs-utils: Disable format-overflow as Werror
authorKhem Raj <raj.khem@gmail.com>
Wed, 26 Dec 2018 20:09:48 +0000 (12:09 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 27 Dec 2018 22:50:01 +0000 (22:50 +0000)
These warnings are intricate and we can ignore that for now as they are
being found by gcc 9, eventually this should be not needed when code
upstream is fixed

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/nfs-utils/nfs-utils_2.3.3.bb

index 6be2aab47c132b7beba5bed3f832157b301d270d..63aa6add5a1412b7516c71a70df1eb13aa292465 100644 (file)
@@ -64,6 +64,8 @@ EXTRA_OECONF = "--with-statduser=rpcuser \
                 --with-statdpath=/var/lib/nfs/statd \
                "
 
+CFLAGS += "-Wno-error=format-overflow"
+
 PACKAGECONFIG ??= "tcp-wrappers \
     ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
 "