]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnutls: upgrade to version 2.8.6
authorQing He <qing.he@intel.com>
Wed, 23 Jun 2010 07:07:39 +0000 (15:07 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Fri, 9 Jul 2010 04:11:00 +0000 (21:11 -0700)
from 2.4.2
add homepage and bugtracker
clarify licensing to GPL & LGPL for different sub packages

changes:
  - use EXTRA_OECONF to explicitly specify libgcrypt path
  - remove multiple aclocal.m4s and distributed libtool m4
    scripts to produce sanity environment, otherwise it may
    complain about libtool version mismatch at compilation
  - rebase configure_madness.patch to adapt new autotools
    scripts, change libgnutls.pc.in and libgnutls-extra.pc.in
    to fix pkg-config issues
  - rebase the other patches
  - remove duplicated inheritence
  - depends explictly on libgcrypt (>= 1.4.2), or configure
    fails
  - use standalone version of libtasn1, and add it as a build
    dependency on libatsn1
  - add --disable-rpath in EXTRA_OECONF to avoid the rpath
    pollution by --with-<pkg>-prefix=

Signed-off-by: Qing He <qing.he@intel.com>
meta/packages/gnutls/gnutls-2.4.2/configure_madness.patch [deleted file]
meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch [new file with mode: 0644]
meta/packages/gnutls/gnutls-2.8.6/gnutls-openssl.patch [moved from meta/packages/gnutls/gnutls-2.4.2/gnutls-openssl.patch with 93% similarity]
meta/packages/gnutls/gnutls-2.8.6/gnutls-texinfo-euro.patch [moved from meta/packages/gnutls/gnutls-2.4.2/gnutls-texinfo-euro.patch with 81% similarity]
meta/packages/gnutls/gnutls.inc
meta/packages/gnutls/gnutls_2.4.2.bb [deleted file]
meta/packages/gnutls/gnutls_2.8.6.bb [new file with mode: 0644]

diff --git a/meta/packages/gnutls/gnutls-2.4.2/configure_madness.patch b/meta/packages/gnutls/gnutls-2.4.2/configure_madness.patch
deleted file mode 100644 (file)
index 19b6b49..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
----
- configure.in                |    8 ++++----
- lib/gnutls.pc.in            |    3 ++-
- libextra/gnutls-extra.pc.in |    3 ++-
- 3 files changed, 8 insertions(+), 6 deletions(-)
-
---- gnutls-2.4.0.orig/configure.in
-+++ gnutls-2.4.0/configure.in
-@@ -637,17 +637,17 @@ AC_MSG_RESULT([***
- *** Detecting options for shared libraries...
- ])
- AC_LIBTOOL_WIN32_DLL
- AC_PROG_LIBTOOL
--LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
--LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS -I${includedir}"
-+LIBGNUTLS_LIBS="-lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
-+LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS"
- AC_SUBST(LIBGNUTLS_LIBS)
- AC_SUBST(LIBGNUTLS_CFLAGS)
--LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
--LIBGNUTLS_EXTRA_CFLAGS="-I${includedir}"
-+LIBGNUTLS_EXTRA_LIBS=" -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
-+LIBGNUTLS_EXTRA_CFLAGS=""
- AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
- AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
- export ac_full
- AM_CFLAGS="${AM_CFLAGS} ${LIBGCRYPT_CFLAGS}"
---- gnutls-2.4.0.orig/lib/gnutls.pc.in
-+++ gnutls-2.4.0/lib/gnutls.pc.in
-@@ -16,8 +16,9 @@ libdir=@libdir@
- includedir=@includedir@
- Name: GnuTLS
- Description: Transport Security Layer implementation for the GNU system
- Version: @VERSION@
-+Requires.private: libgcrypt
- Libs: -L${libdir} -lgnutls
--Libs.private: @LIBGNUTLS_LIBS@ 
-+Libs.private: -L${libdir} -lgnutls
- Cflags: -I${includedir}
---- gnutls-2.4.0.orig/libextra/gnutls-extra.pc.in
-+++ gnutls-2.4.0/libextra/gnutls-extra.pc.in
-@@ -16,9 +16,10 @@ libdir=@libdir@
- includedir=@includedir@
- Name: GnuTLS-extra
- Description: Additional add-ons for GnuTLS licensed under GPL
- Requires: gnutls
-+Requires.private: gnutls
- Version: @VERSION@
- Libs: -L${libdir} -lgnutls-extra
--Libs.private: @LIBGNUTLS_EXTRA_LIBS@
-+Libs.private: -L${libdir} -lgnutls-extra
- Cflags: -I${includedir}
diff --git a/meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch b/meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch
new file mode 100644 (file)
index 0000000..247e324
--- /dev/null
@@ -0,0 +1,64 @@
+rebased from original configure_madness.patch
+
+libtasn1 provides an .pc file in upstream,
+and a libgcrypt.pc is added in libgcrypt recipe,
+so use Requires.private for these two.
+
+against 2.8.6
+
+07/02/2010 - qhe
+
+---
+diff --git a/lib/configure.ac b/lib/configure.ac
+index 80d3375..1a486f7 100644
+--- a/lib/configure.ac
++++ b/lib/configure.ac
+@@ -81,8 +81,8 @@ fi
+ lgl_INIT
+-LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBS"
+-LIBGNUTLS_CFLAGS="-I${includedir}"
++LIBGNUTLS_LIBS="-lgnutls $LIBS"
++LIBGNUTLS_CFLAGS=""
+ AC_SUBST(LIBGNUTLS_LIBS)
+ AC_SUBST(LIBGNUTLS_CFLAGS)
+diff --git a/lib/gnutls.pc.in b/lib/gnutls.pc.in
+index 3b01c17..de31469 100644
+--- a/lib/gnutls.pc.in
++++ b/lib/gnutls.pc.in
+@@ -20,6 +20,6 @@ Name: GnuTLS
+ Description: Transport Security Layer implementation for the GNU system
+ URL: http://www.gnu.org/software/gnutls/
+ Version: @VERSION@
++Requires.private: libgcrypt, libtasn1
+ Libs: -L${libdir} -lgnutls
+-Libs.private: @LIBGNUTLS_LIBS@ @LTLIBTASN1@
+ Cflags: -I${includedir}
+diff --git a/libextra/configure.ac b/libextra/configure.ac
+index c08e73f..3313886 100644
+--- a/libextra/configure.ac
++++ b/libextra/configure.ac
+@@ -40,8 +40,8 @@ LIBGNUTLS_EXTRA_HOOKS
+ xgl_INIT
+-LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
+-LIBGNUTLS_EXTRA_CFLAGS="-I${includedir}"
++LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
++LIBGNUTLS_EXTRA_CFLAGS=""
+ AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
+ AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
+diff --git a/libextra/gnutls-extra.pc.in b/libextra/gnutls-extra.pc.in
+index 9e7b8f6..e228ec9 100644
+--- a/libextra/gnutls-extra.pc.in
++++ b/libextra/gnutls-extra.pc.in
+@@ -21,5 +21,5 @@ URL: http://www.gnu.org/software/gnutls/
+ Requires: gnutls
+ Version: @VERSION@
+ Libs: -L${libdir} -lgnutls-extra
+-Libs.private: @LIBGNUTLS_EXTRA_LIBS@
++Libs.private: -llzo2
+ Cflags: -I${includedir}
similarity index 93%
rename from meta/packages/gnutls/gnutls-2.4.2/gnutls-openssl.patch
rename to meta/packages/gnutls/gnutls-2.8.6/gnutls-openssl.patch
index e2c189592fa323465c0239d29430e44c1780063a..413de0647284f742c14cb02c1aba495839335b9e 100644 (file)
@@ -108,8 +108,8 @@ Index: gnutls-1.6.0/libextra/gnutls_openssl.c
  
 Index: gnutls-1.6.0/includes/gnutls/openssl.h
 ===================================================================
---- gnutls-1.6.0.orig/includes/gnutls/openssl.h        2006-03-08 11:44:58.000000000 +0100
-+++ gnutls-1.6.0/includes/gnutls/openssl.h     2006-12-12 15:07:26.032227000 +0100
+--- gnutls-1.6.0.orig/libextra/includes/gnutls/openssl.h       2006-03-08 11:44:58.000000000 +0100
++++ gnutls-1.6.0/libextra/includes/gnutls/openssl.h    2006-12-12 15:07:26.032227000 +0100
 @@ -164,6 +164,11 @@
  
      gnutls_transport_ptr_t rfd;
similarity index 81%
rename from meta/packages/gnutls/gnutls-2.4.2/gnutls-texinfo-euro.patch
rename to meta/packages/gnutls/gnutls-2.8.6/gnutls-texinfo-euro.patch
index e2a2762424c87d3a40977698e38fff494e09110d..a2d2f038704a5ac78d21522701a1973d073a768d 100644 (file)
@@ -1,8 +1,8 @@
 The version of texinfo in Debian Sarge does not understand the @euro{} command.
 This patch replaces the @euro{} command with the word "euro".
 
---- gnutls-1.3.5/doc/signatures.texi.orig      2006-04-26 08:06:40.918268000 +0930
-+++ gnutls-1.3.5/doc/signatures.texi   2006-04-26 08:06:52.446515440 +0930
+--- gnutls-1.3.5/doc/gnutls.texi.orig  2006-04-26 08:06:40.918268000 +0930
++++ gnutls-1.3.5/doc/gnutls.texi       2006-04-26 08:06:52.446515440 +0930
 @@ -11,8 +11,8 @@
  long as it is difficult enough to generate two different messages with
  the same hash algorithm output. In that case the same signature could
index 474812598af7c43a577cc3d3cf78cd55745d448e..76f4ca63fd98039ed42510b89ce4b1d3ecb6a58b 100644 (file)
@@ -1,14 +1,32 @@
 DESCRIPTION = "GNU Transport Layer Security Library"
 HOMEPAGE = "http://www.gnu.org/software/gnutls/"
-DEPENDS = "zlib libgcrypt lzo gettext"
+BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
+DEPENDS = "zlib lzo gettext libtasn1 libgcrypt (>= 1.4.2)"
 
-LICENSE = "LGPL"
+LICENSE = "GPLv3+ & LGPLv2.1+"
+LICENSE_${PN} = "LGPLv2.1+"
+LICENSE_${PN}-xx = "GPLv2.1+"
+LICENSE_${PN}-bin = "GPLv3+"
+LICENSE_${PN}-extra = "GPLv3+"
+LICENSE_${PN}-openssl = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+                    file://lib/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
+                    file://libextra/COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
 SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2"
 
-inherit autotools binconfig pkgconfig pkgconfig
+inherit autotools binconfig pkgconfig
 
-EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1 --with-included-libcfg --with-libz-prefix=${STAGING_DIR_HOST}${prefix} --with-lzo --disable-guile"
+EXTRA_OECONF="--with-included-opencdk --with-included-libcfg --disable-rpath \
+              --with-libtasn1-prefix=${STAGING_DIR_HOST}${prefix} \
+              --with-libgcrypt-prefix=${STAGING_DIR_HOST}${prefix} \
+              --with-libz-prefix=${STAGING_DIR_HOST}${prefix} --with-lzo --disable-guile"
+
+do_configure_prepend() {
+       for dir in . lib libextra; do
+               rm ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
+       done
+}
 
 PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin ${PN}-xx"
 
diff --git a/meta/packages/gnutls/gnutls_2.4.2.bb b/meta/packages/gnutls/gnutls_2.4.2.bb
deleted file mode 100644 (file)
index 150c97c..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-require gnutls.inc
-
-PR = "r1"
-
-SRC_URI += "\
-       file://gnutls-openssl.patch;patch=1 \
-       file://gnutls-texinfo-euro.patch;patch=1 \
-       file://configure_madness.patch;patch=1 \
-       "
diff --git a/meta/packages/gnutls/gnutls_2.8.6.bb b/meta/packages/gnutls/gnutls_2.8.6.bb
new file mode 100644 (file)
index 0000000..d8adc6b
--- /dev/null
@@ -0,0 +1,7 @@
+require gnutls.inc
+
+PR = "r0"
+
+SRC_URI += "file://gnutls-openssl.patch \
+            file://gnutls-texinfo-euro.patch \
+            file://configure-fix.patch"