]> code.ossystems Code Review - openembedded-core.git/commitdiff
Remove exclude hack in insane.bbclass and replace it with something a little less...
authorRoss Burton <ross@openedhand.com>
Mon, 22 Jan 2007 20:11:19 +0000 (20:11 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 22 Jan 2007 20:11:19 +0000 (20:11 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1197 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta-extras/packages/networkmanager/networkmanager_svn.bb
meta/classes/insane.bbclass
meta/packages/db/db_4.2.52.bb
meta/packages/elfutils/elfutils_0.108.bb
meta/packages/gcc/gcc-package.inc

index e0e19f8cfd2483696bbb67bc3951841eeb68a3db..f3ebf48a8816e2d8b0047b9bd8ad324b537acde0 100644 (file)
@@ -56,3 +56,7 @@ FILES_${PN} += "${datadir} \
 FILES_${PN}-dev = "${incdir} \
                   ${libdir}/*.a \
                   ${libdir}/pkgconfig"
+
+# The networkmanager package needs to be split into app/lib/dev packages. For
+# now, silence insane.
+INSANE_SKIP_${PN} = "1"
index b3fc72a4656c595509e8f2ec486245c6c14eedb4..09728f850e96814f79403a7708bb1aa1a84bc882 100644 (file)
@@ -101,7 +101,7 @@ def package_qa_check_rdepends(pkg, workdir, d):
 
         bb.data.setVar('ROOT', '', localdata) 
         bb.data.setVar('ROOT_%s' % pkg, root, localdata)
-        pkgname = bb.data.getVar('PKG_%s' % pkg, localdata, 1)
+        pkgname = bb.data.getVar('PKG_%s' % pkg, localdata, True)
         if not pkgname:
             pkgname = pkg
         bb.data.setVar('PKG', pkgname, localdata)
@@ -134,12 +134,7 @@ python do_package_qa () {
         return
 
     for package in packages.split():
-        # Nasty hack for now until we can mark exclusions in the packages.
-        # db has a unusual versioning scheme. Cannot fix this.
-        # gcc contains symlinks to other packages. Cannot fix.
-        # elfutils has symlinks to point to correct .so files. Cannot fix.
-        # networkmanager needs to be split into app/lib packages. Can fix.
-        if package in [ 'db', 'gcc', 'elfutils', 'networkmanager' ]:
+        if bb.data.getVar('INSANE_SKIP_' + package, d, True):
             bb.note("Package: %s (skipped)" % package)
             continue
         
index 05565287f51ac33b2ed6b6e0aa5a7d7c8a3a15fd..5c674f1aa8f2d3fe91a4e1be9948614c5154a7d2 100644 (file)
@@ -95,3 +95,6 @@ do_install_append() {
                mv "${D}/${prefix}/docs" "${D}/${docdir}"
        fi
 }
+
+# The db package contains symlinks that trip up insane
+INSANE_SKIP_db = "1"
index 83acc7dccb2095578b778dfa8fe828829581d6ec..a1f7b2fc5c0ceb279264bc0979b15b2e2140abba 100644 (file)
@@ -34,3 +34,6 @@ do_stage () {
        install -m 0644 ${S}/libdw/libdw.h ${STAGING_INCDIR}/elfutils/
        install -m 0644 ${S}/libasm/libasm.h ${STAGING_INCDIR}/elfutils/
 }
+
+# The elfutils package contains symlinks that trip up insane
+INSANE_SKIP_elfutils = "1"
index 7dbb2acc35aea41df07de8c55aeb375963be1f02..22c1d809db2305985e7459bcf3d7a9bfe7fadf68 100644 (file)
@@ -107,3 +107,6 @@ do_install () {
        ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${base_libdir}/cpp
        ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${bindir}/cpp
 }
+
+# The gcc package contains symlinks that trip up insane
+INSANE_SKIP_${PN} = "1"