]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev: Fix touchscreen link creation with latest version
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 25 Nov 2009 14:31:53 +0000 (14:31 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 25 Nov 2009 14:31:53 +0000 (14:31 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/udev/udev-145/local.rules
meta/packages/udev/udev_145.bb

index 5b926018f56139587f0be758d575ba17e11ea289..dab319b431378e7c1ac6da2b5a4c0383f19011bc 100644 (file)
@@ -28,4 +28,6 @@ KERNEL=="rtc0", SYMLINK+="rtc"
 ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
 
 # Create a symlink to any touchscreen input device
-SUBSYSTEM=="input", KERNEL=="event[0-9]*", SYSFS{modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
+# Need to use ../ so the eventX can find the parent inputX modalias which is a directory above
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{../modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
+
index ab455570ba6779d7590f80dfa364e75d288f8942..ab5d3fe458c58039b669ca050a1eaf5504922eec 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 the hotplug package and requires a kernel not older than 2.6.12."
 RPROVIDES_${PN} = "hotplug"
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
           file://run.rules \