]> code.ossystems Code Review - openembedded-core.git/commitdiff
glib-2.0: don't disable all debugging functionality
authorRoss Burton <ross.burton@intel.com>
Thu, 30 Aug 2012 14:51:59 +0000 (15:51 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 30 Aug 2012 23:53:38 +0000 (16:53 -0700)
GLib will use "minimal" debugging on non-development builds and the extra safety
net and ability to debug at all is totally worth the small performance cost.

If someone has a need for every ounce of performance, a simple .bbappend can
restore this option.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
meta/recipes-core/glib-2.0/glib.inc

index 8f7cd69f82bfee5ac0a1961fc8ffe8fbd7c48fdf..7bc97d68d3d7dc410a1ac871169171a46717167e 100644 (file)
@@ -1,6 +1,6 @@
 require glib.inc
 
-PR = "r4"
+PR = "r5"
 PE = "1"
 
 DEPENDS += "libffi python-argparse-native zlib"
index 3540cd57690e556cf2cb598dac3add4d488ff9b0..9dca440e80d0957515f65d4bda63691904a9f3cf 100644 (file)
@@ -27,7 +27,7 @@ S = "${WORKDIR}/glib-${PV}"
 
 CORECONF = "--disable-dtrace --disable-fam --disable-libelf --disable-systemtap"
 
-EXTRA_OECONF = "--disable-debug --enable-included-printf=no ${CORECONF}"
+EXTRA_OECONF = "--enable-included-printf=no ${CORECONF}"
 EXTRA_OECONF_virtclass-native = "${CORECONF}"
 EXTRA_OECONF_linuxstdbase = "--enable-included-printf=no ${CORECONF}"