]> code.ossystems Code Review - openembedded-core.git/commitdiff
pcihp: fix possible array out of bounds, CVE-2014-5388
authorSona Sarmadi <sona.sarmadi@enea.com>
Fri, 5 Sep 2014 10:04:08 +0000 (12:04 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Sep 2014 14:19:57 +0000 (15:19 +0100)
Prevent out-of-bounds array access on acpi_pcihp_pci_status.

[From QEMU: fa365d7cd11185237471823a5a33d36765454e16]

Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/qemu/files/0001-Back-porting-security-fix-CVE-2014-5388.patch [new file with mode: 0644]
meta/recipes-devtools/qemu/qemu_2.1.0.bb

diff --git a/meta/recipes-devtools/qemu/files/0001-Back-porting-security-fix-CVE-2014-5388.patch b/meta/recipes-devtools/qemu/files/0001-Back-porting-security-fix-CVE-2014-5388.patch
new file mode 100644 (file)
index 0000000..ec541fa
--- /dev/null
@@ -0,0 +1,30 @@
+Prevent out-of-bounds array access on
+acpi_pcihp_pci_status.
+
+Upstream-Status: Backport
+
+Signed-off-by: Gonglei <arei.gonglei@huawei.com>
+Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
+---
+v2:
+ - change commit message.
+ - add 'Reviewed-by'
+---
+ hw/acpi/pcihp.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/hw/acpi/pcihp.c b/hw/acpi/pcihp.c
+index fae663a..34dedf1 100644
+--- a/hw/acpi/pcihp.c
++++ b/hw/acpi/pcihp.c
+@@ -231,7 +231,7 @@ static uint64_t pci_read(void *opaque, hwaddr addr, unsigned int size)
+     uint32_t val = 0;
+     int bsel = s->hotplug_select;
+
+-    if (bsel < 0 || bsel > ACPI_PCIHP_MAX_HOTPLUG_BUS) {
++    if (bsel < 0 || bsel >= ACPI_PCIHP_MAX_HOTPLUG_BUS) {
+         return 0;
+     }
+
+--
+1.7.12.4
index 9b8337a73d5ba9aacf67f45d9d46dd9b4db77ccb..a82d0529b9778c767d5993069e915146d3ac9f3b 100644 (file)
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
 SRC_URI += "file://configure-fix-Darwin-target-detection.patch \
             file://qemu-enlarge-env-entry-size.patch \
             file://Qemu-Arm-versatilepb-Add-memory-size-checking.patch \
+            file://0001-Back-porting-security-fix-CVE-2014-5388.patch \
             "
 SRC_URI_prepend = "http://wiki.qemu-project.org/download/${BP}.tar.bz2"
 SRC_URI[md5sum] = "6726977292b448cbc7f89998fac6983b"