]> code.ossystems Code Review - openembedded-core.git/commitdiff
parted: improve ptest execution
authorRoss Burton <ross@burtonini.com>
Fri, 9 Jul 2021 11:08:47 +0000 (12:08 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 10 Jul 2021 21:40:12 +0000 (22:40 +0100)
Delete the right log files in run-ptest so the tests can be executed
more than once.

Install config.h so the tests which examine the build configuration will
do the right thing, specifically this causes the tests using libblkid to
execute instead of skip.

Add missing RDEPENDS: mkswap and tune2fs binaries, loop and vfat kernel
modules.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/parted/files/run-ptest
meta/recipes-extended/parted/parted_3.4.bb

index 374f1bfbc9b1abc287f25d642fa4b7fdcb3d1844..c3d6fca3391606fdeb7771b84c2b97d3d6d5be79 100644 (file)
@@ -2,6 +2,6 @@
 
 mkdir -p /etc/udev/mount.blacklist.d
 echo /dev/sda1 >> /etc/udev/mount.blacklist.d/parted-tmp
-rm -f *.log
+rm -f tests/*.log
 make -C tests test-suite.log
 rm /etc/udev/mount.blacklist.d/parted-tmp
index fb583489f838e73bde38d7457b0fae67a735c308..4b76ca486166971bb04eba2c7116cc23d9354c04 100644 (file)
@@ -35,10 +35,13 @@ do_install_ptest() {
        cp ${S}/build-aux/test-driver $t/build-aux/
        cp -r ${S}/tests $t
        cp ${B}/tests/Makefile $t/tests/
+       mkdir $t/lib
+       cp ${B}/lib/config.h $t/lib
        sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
        sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile
        sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile
-       sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = \.\.|g" $t/tests/Makefile
+       sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = "${PTEST_PATH}"|g" $t/tests/Makefile
+       sed -i "s|^abs_top_builddir =.*|abs_top_builddir = "${PTEST_PATH}"|g" $t/tests/Makefile
        sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile
        sed -i "/^BUILDINFO.*$/d" $t/tests/Makefile
        for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \
@@ -46,9 +49,8 @@ do_install_ptest() {
        done
        sed -e 's| ../parted||' -i $t/tests/*.sh
 }
-
-RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs python3-core dosfstools"
-RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug"
+RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup util-linux-mkswap python3 make gawk e2fsprogs-mke2fs e2fsprogs-tune2fs python3-core dosfstools"
+RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug kernel-module-loop kernel-module-vfat"
 RDEPENDS_${PN}-ptest_append_libc-glibc = "\
         glibc-utils \
         locale-base-en-us \