]> code.ossystems Code Review - openembedded-core.git/commitdiff
fakeroot: upgrade to 1.14.4
authorKevin Tian <kevin.tian@intel.com>
Wed, 7 Jul 2010 11:15:40 +0000 (19:15 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Fri, 9 Jul 2010 04:05:41 +0000 (21:05 -0700)
[Patches]
  KEEP    _absolutepaths.patch_: solve python link issue
  REMOVE  _configure-libtool.patch_: an old patch, not required now

[Recipe]
  manually create build-aux since its own bootstrap contains more than we want

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/packages/fakeroot/fakeroot-1.14.4/absolutepaths.patch [moved from meta/packages/fakeroot/fakeroot/absolutepaths.patch with 100% similarity]
meta/packages/fakeroot/fakeroot/configure-libtool.patch [deleted file]
meta/packages/fakeroot/fakeroot_1.14.4.bb [moved from meta/packages/fakeroot/fakeroot_1.9.4.bb with 72% similarity]

diff --git a/meta/packages/fakeroot/fakeroot/configure-libtool.patch b/meta/packages/fakeroot/fakeroot/configure-libtool.patch
deleted file mode 100644 (file)
index 8830328..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- fakeroot-1.8.3/configure.ac.orig   2007-10-31 00:17:27.000000000 -0500
-+++ fakeroot-1.8.3/configure.ac        2007-10-31 00:18:12.000000000 -0500
-@@ -1,14 +1,12 @@
- dnl Process this file with autoconf to produce a configure script.
- AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
- AC_PREREQ(2.61)
--LT_PREREQ(2.1a)
- AC_CANONICAL_TARGET
- AM_INIT_AUTOMAKE
- AM_MAINTAINER_MODE
- AC_CONFIG_HEADERS([config.h])
- AC_PROG_MAKE_SET
--LT_INIT
--LT_LANG(C)
-+AC_PROG_LIBTOOL
- AC_ARG_WITH([ipc],
-           AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],
similarity index 72%
rename from meta/packages/fakeroot/fakeroot_1.9.4.bb
rename to meta/packages/fakeroot/fakeroot_1.14.4.bb
index 66193171fcc863b809a13ea5b4e01c06337b29c7..11ae015a83047189dbb67b552e0d6f9dd188341b 100644 (file)
@@ -5,14 +5,19 @@ LICENSE = "GPLv2"
 # fakeroot needs getopt which is provided by the util-linux package
 RDEPENDS = "util-linux"
 RDEPENDS_virtclass-native = "util-linux-native"
-PR = "r3"
+PR = "r0"
 
-SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
-           file://configure-libtool.patch; \
-           file://absolutepaths.patch;"
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
+           file://absolutepaths.patch"
            
 inherit autotools
 
+do_configure_prepend() {
+       # fakeroot's own bootstrap includes other autoreconf stuff we don't need here
+       # so manually create the aux directory
+       mkdir -p ${S}/build-aux
+}
+
 do_install_append() {
        install -d ${D}${STAGING_INCDIR}/fakeroot/
        install -m 644 *.h ${D}${STAGING_INCDIR}/fakeroot