]> code.ossystems Code Review - openembedded-core.git/commitdiff
Disable packaged-staging for cross-linkage/staging-linkage and external-poky-toolchain
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 19 Nov 2009 13:37:11 +0000 (13:37 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 19 Nov 2009 13:37:11 +0000 (13:37 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/classes/packaged-staging.bbclass
meta/packages/meta/cross-linkage_1.0.bb
meta/packages/meta/external-poky-toolchain.bb
meta/packages/meta/staging-linkage_1.0.bb

index 8bbbc0cb13bc01dc8e35acdb59b3f84ddcca5221..9a20761ff3000d85488d7f5510d6043beda6b0b4 100644 (file)
@@ -48,6 +48,9 @@ python () {
     if bb.data.inherits_class('image', d):
         pstage_allowed = False
 
+    if bb.data.getVar('PSTAGING_DISABLED', d, True) == "1":
+        pstage_allowed = False
+
     # Add task dependencies if we're active, otherwise mark packaged staging
     # as inactive.
     if pstage_allowed:
index b20dc1d6d536ada011d119488ee337dc956e5057..9e6ac4ad0ab394733513ee13d5e89bda494e55f3 100644 (file)
@@ -16,6 +16,8 @@ do_compile () {
        :
 }
 
+PSTAGING_DISABLED = "1"
+
 do_install() {
        install -d ${CROSS_DIR}/${TARGET_SYS}/
        if [ -e ${CROSS_DIR}/${TARGET_SYS}/include ]; then
index 77b5a2805acc2151842358446389bc8900d3819f..081eff6ad842ffa3cc90a9a36a4396dfeb8c1972 100644 (file)
@@ -14,6 +14,8 @@ PACKAGES_DYNAMIC = "glibc-gconv-*"
 INHIBIT_DEFAULT_DEPS = "1"
 PR = "r1"
 
+PSTAGING_DISABLED = "1"
+
 do_install() {
        if [ ! -e  ${prefix}/environment-setup ]; then
                echo "The Poky toolchain could not be found in ${prefix}!"
index 4084e4c63c0ab03c1b96d33a1a6802c9a814383c..9ecc0d5af1d77467c41046034e41f7880edae60f 100644 (file)
@@ -16,6 +16,8 @@ do_compile () {
        :
 }
 
+PSTAGING_DISABLED = "1"
+
 do_install () {
        if [ -e ${STAGING_DIR_HOST}${base_libdir} ]; then
                cp -pPRr ${STAGING_DIR_HOST}${base_libdir}/* ${STAGING_LIBDIR}