]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Change config option
authorMark Hatle <mark.hatle@windriver.com>
Fri, 24 Jun 2011 18:27:09 +0000 (13:27 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 28 Jun 2011 12:50:44 +0000 (13:50 +0100)
For some reason --without-xz doesn't work the same as --with-xz=none.

We need this set to none, or configure will attempt to find an lzma
header which we might or might not have.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/rpm/rpm_5.4.0.bb

index 0c88f91761ba10c2d28cc6b1b20740427da06a3c..91089d21d90783200f8f717537a56497bb0c7f8d 100644 (file)
@@ -84,7 +84,7 @@ rpm_macros_virtclass-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{
 # Configure values taken from rpm.spec
 WITH_BZIP2 = "--with-bzip2"
 
-WITH_XZ = "--without-xz"
+WITH_XZ = "--with-xz=none"
 
 WITH_Z = "--with-zlib $WITH_BZIP2 $WITH_XZ"