]> code.ossystems Code Review - openembedded-core.git/commitdiff
fotowall: add QT app fotowall, an QT photo tool
authorYu Ke <ke.yu@intel.com>
Wed, 25 Aug 2010 03:12:59 +0000 (11:12 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 27 Aug 2010 12:29:52 +0000 (13:29 +0100)
Add fotowall from qt-apps.org to validate and demo qt library. fotowall is a creative tool that allows you to layout your photos or pictures.

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta-lsb/packages/qt-apps/fotowall_0.9.bb [new file with mode: 0644]

diff --git a/meta-lsb/packages/qt-apps/fotowall_0.9.bb b/meta-lsb/packages/qt-apps/fotowall_0.9.bb
new file mode 100644 (file)
index 0000000..4070ac5
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Fotowall is a creative tool that allows you to layout your photos or pictures \
+in a personal way. You can add pictures, then resize, move, change colors, text, shadows, etc.."
+
+HOMEPAGE = "http://www.enricoros.com/opensource/fotowall"
+LICENSE = "GPLv2+"
+SECTION = "x11/apps"
+
+DEPENDS = "qt4-x11-free"
+RDEPENDS = "qt4-x11-free"
+
+SRC_URI = "http://qt-apps.org/CONTENT/content-files/71316-Fotowall-0.9.tar.bz2"
+
+S = "${WORKDIR}/Fotowall-${PV}"
+
+inherit qmake2 pkgconfig
+
+do_install() {
+       oe_runmake INSTALL_ROOT=${D} install
+}