]> code.ossystems Code Review - openembedded-core.git/commitdiff
llvm: update from 8.0.0rc2 to 8.0.0 final release
authorAlexander Kanavin <alex.kanavin@gmail.com>
Wed, 27 Mar 2019 14:09:21 +0000 (15:09 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Mar 2019 08:28:55 +0000 (08:28 +0000)
Also, update PV to match the version scheme used by upstream
to tag releases (e.g. major.minor.patch).

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/llvm/llvm_git.bb

index 2a8cd4a3e4e52b22c222afe93d5a0c8b55416fc2..01a7da8ebdca0d0c235fffa19b3a751910efcce7 100644 (file)
@@ -19,18 +19,14 @@ PROVIDES += "llvm${PV}"
 LLVM_RELEASE = "${PV}"
 LLVM_DIR = "llvm${LLVM_RELEASE}"
 
-# SRCREV is set to the revision of 8.0.0-rc2 tag, while latest release
-# tag is 7.0.1 as of Feb 18 2019, hence the need for UPSTREAM_CHECK_UNKNOWN
-# Remove the UPSTREAM_VERSION_UNKNOWN line once 8.0.0 final is tagged
-UPSTREAM_VERSION_UNKNOWN = "1"
-SRCREV = "98ebe7460199b9cd79eb562b5e8705ad28f5513f"
+SRCREV = "d2298e74235598f15594fe2c99bbac870a507c59"
 
 BRANCH = "release/${MAJOR_VERSION}.x"
 MAJOR_VERSION = "8"
 MINOR_VERSION = "0"
 PATCH_VERSION = "0"
 SOLIBVER = "1"
-PV = "${MAJOR_VERSION}.${MINOR_VERSION}"
+PV = "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}"
 SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
            file://0001-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \
            file://0002-llvm-allow-env-override-of-exe-path.patch \