]> code.ossystems Code Review - openembedded-core.git/commitdiff
BSP Guide Makefile: HTML generation debugging edits.
authorScott Rifenbark <scott.m.rifenbark@intel.com>
Tue, 9 Nov 2010 17:41:05 +0000 (09:41 -0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 15 Nov 2010 22:25:24 +0000 (22:25 +0000)
I am getting occasional errors while attempting to make the HTML version
of this manual.  The error is generated from line 367 of the html.xsl
style sheet and seems to come from confusion of not finding the css
style sheet parameter.  Here is the error from the shell window.

scottrif@scottrif-desktop:~/poky/documentation/bsp-guide$ make html
xsltproc --stringparam html.stylesheet style.css --stringparam  chapter.autolabel 1 --stringparam  section.autolabel 1 --stringparam  section.label.includes.component.label 1 --xinclude -o bsp-guide.html http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl bsp-guide.xml
Note: namesp. cut : stripped namespace before processing
WARNING: cannot add @xml:base to node set root element.  Relative paths may not work.
Note: namesp. cut : processing stripped document
runtime error: file http://docbook.sourceforge.net/release/xsl/current/xhtml/html.xsl line 367 element choose
Variable 'generate.css.header' has not been declared.
make: *** [html] Error 10

The odd think is that running "make html" immediately again could cause the
make to be entirely successful.

So this commit involved moving the XSLTOPTS parameters to the top of the
make file and the *_URI parameter declarations to the top as well.  This
takes them out of the "pdf" area of the make file and they should be
more universal.  The reason I tried this is because I have no such issues
when building the yocto-project-qs HTML file.

However, even with these changes the occasional runtime error (shown above)
still occurs.

Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
documentation/bsp-guide/Makefile

index 4cf6533be71c20e2732b1a4188abebaf20dfb1de..d2f29aa53fc8b2cddb3ee5b91b4ede7fa0bda222 100644 (file)
@@ -1,8 +1,3 @@
-all: html pdf tarball
-
-pdf:
-       ../tools/poky-docbook-to-pdf bsp-guide.xml ../template
-
 XSLTOPTS = --stringparam html.stylesheet style.css \
            --stringparam  chapter.autolabel 1 \
            --stringparam  section.autolabel 1 \
@@ -15,6 +10,11 @@ XSLTOPTS = --stringparam html.stylesheet style.css \
 XSL_BASE_URI  = http://docbook.sourceforge.net/release/xsl/current
 XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
 
+all: html pdf tarball
+
+pdf:
+       ../tools/poky-docbook-to-pdf bsp-guide.xml ../template
+
 html:
 #       See http://www.sagehill.net/docbookxsl/HtmlOutput.html 
        xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSL_XHTML_URI) bsp-guide.xml