]> code.ossystems Code Review - openembedded-core.git/commitdiff
ffmpeg, gstreamer1.0-libav: add textrel INSANE_SKIPs
authorJussi Kukkonen <jussi.kukkonen@intel.com>
Wed, 6 Apr 2016 08:19:12 +0000 (11:19 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 6 Apr 2016 09:31:00 +0000 (10:31 +0100)
ffmpeg disables PIC on some platforms even when --enable-pic is
set, apparently for performance reasons. Add INSANE_SKIPS for the
relevant packages.

Fixes [YOCTO #9375].

Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb
meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc

index 0296ada0aa6c471800f96656dbcb4f8e1c8dcf6b..1dfbb9b04c32e681b2de393a570590f2ca76071b 100644 (file)
@@ -94,6 +94,17 @@ do_configure() {
 
 PACKAGES_DYNAMIC += "^lib(av(codec|device|filter|format|util|resample)|swscale|swresample|postproc).*"
 
+# ffmpeg disables PIC on some platforms (e.g. x86-32)
+INSANE_SKIP_${MLPREFIX}libavcodec = "textrel"
+INSANE_SKIP_${MLPREFIX}libavdevice = "textrel"
+INSANE_SKIP_${MLPREFIX}libavfilter = "textrel"
+INSANE_SKIP_${MLPREFIX}libavformat = "textrel"
+INSANE_SKIP_${MLPREFIX}libavutil = "textrel"
+INSANE_SKIP_${MLPREFIX}libavresample = "textrel"
+INSANE_SKIP_${MLPREFIX}libswscale = "textrel"
+INSANE_SKIP_${MLPREFIX}libswresample = "textrel"
+INSANE_SKIP_${MLPREFIX}libpostproc = "textrel"
+
 python populate_packages_prepend() {
     av_libdir = d.expand('${libdir}')
     av_pkgconfig = d.expand('${libdir}/pkgconfig')
index 598a349e0222002cc3273a5df517757d11d7966a..363101e1a4949e7756981947335cb88f6ab1c8a8 100644 (file)
@@ -41,3 +41,6 @@ FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
 # http://errors.yoctoproject.org/Errors/Details/20493/
 ARM_INSTRUCTION_SET_armv4 = "arm"
 ARM_INSTRUCTION_SET_armv5 = "arm"
+
+# ffmpeg/libav disables PIC on some platforms (e.g. x86-32)
+INSANE_SKIP_${PN} = "textrel"