]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-keyboard: Change session script to start it after the desktop using dbus...
authorRichard Purdie <richard@openedhand.com>
Tue, 19 Aug 2008 16:06:48 +0000 (16:06 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 19 Aug 2008 16:06:48 +0000 (16:06 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5073 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-keyboard/files/80matchboxkeyboard.shbg [moved from meta/packages/matchbox-keyboard/files/80matchboxkeyboard with 72% similarity]
meta/packages/matchbox-keyboard/matchbox-keyboard_svn.bb

similarity index 72%
rename from meta/packages/matchbox-keyboard/files/80matchboxkeyboard
rename to meta/packages/matchbox-keyboard/files/80matchboxkeyboard.shbg
index 7c775af0eb7fd0fad0cc21ed1ccf83907603ba8f..e6745c5695244b9a4666acfb033e6d369193faf7 100755 (executable)
@@ -14,8 +14,10 @@ elif [ "$DISPLAY_CAN_ROTATE" = "1" ]; then
     fi
 fi
                                        
-# Delay to make sure the window manager is active
 
 if [ "$CMD" ]; then
-    { sleep 2 ; $CMD ; } &
+    # Delay to make sure the window manager is active
+    # by waiting for the desktop to say its finished loading
+    dbus-wait org.matchbox_project.desktop Loaded
+    $CMD
 fi
index 13635cbaf1014a4dd4054e0afa4ff68e6e45ce6b..7afe8eb60f5afebd2d23b8b077b72e0093a10c0e 100644 (file)
@@ -1,14 +1,14 @@
 DESCRIPTION = "Matchbox virtual keyboard for X11"
 LICENSE = "GPL"
 DEPENDS = "libfakekey expat libxft gtk+ matchbox-panel-2"
-RDEPENDS = "formfactor"
+RDEPENDS = "formfactor dbus-wait"
 SECTION = "x11"
 PV = "0.0+svnr${SRCREV}"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
            file://configure_fix.patch;patch=1;maxrev=1819 \
-          file://80matchboxkeyboard"
+          file://80matchboxkeyboard.shbg"
 
 S = "${WORKDIR}/${PN}"
 
@@ -33,7 +33,7 @@ FILES_matchbox-keyboard-applet-dbg += "${libdir}/matchbox-panel/.debug"
 
 do_install_append () {
        install -d ${D}/${sysconfdir}/X11/Xsession.d/
-       install -m 755 ${WORKDIR}/80matchboxkeyboard ${D}/${sysconfdir}/X11/Xsession.d/
+       install -m 755 ${WORKDIR}/80matchboxkeyboard.shbg ${D}/${sysconfdir}/X11/Xsession.d/
 }
 
 pkg_postinst_matchbox-keyboard-im () {