]> code.ossystems Code Review - openembedded-core.git/commitdiff
npth: fix multilib header conflict-npth.h
authorZhixiong Chi <zhixiong.chi@windriver.com>
Thu, 19 Apr 2018 10:18:06 +0000 (03:18 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 4 May 2018 08:54:57 +0000 (09:54 +0100)
Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/npth/npth_1.5.bb

index e7db6ae1b4b4e109fa786f12ebb6efab65849763..8f42a1a2f9cad7d1ac7d648c41dcdb58431949e7 100644 (file)
@@ -15,9 +15,13 @@ SRC_URI[sha256sum] = "294a690c1f537b92ed829d867bee537e46be93fbd60b16c04630fbbfcd
 
 BINCONFIG = "${bindir}/npth-config"
 
-inherit autotools binconfig-disabled
+inherit autotools binconfig-disabled multilib_header 
 
 FILES_${PN} = "${libdir}/libnpth.so.*"
 FILES_${PN}-dev += "${bindir}/npth-config"
 
+do_install_append() {
+    oe_multilib_header npth.h
+}
+
 BBCLASSEXTEND = "native"