]> code.ossystems Code Review - openembedded-core.git/commitdiff
clutter-gst: Replace with 1.6.0 version
authorTomas Frydrych <tomas@sleepfive.com>
Mon, 20 May 2013 15:05:22 +0000 (16:05 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 May 2013 08:14:37 +0000 (09:14 +0100)
Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/clutter/clutter-gst-1.0.inc [new file with mode: 0644]
meta/recipes-graphics/clutter/clutter-gst-1.0_1.6.0.bb [new file with mode: 0644]
meta/recipes-graphics/clutter/clutter-gst-1.6/cogl-1.14.patch [new file with mode: 0644]
meta/recipes-graphics/clutter/clutter-gst-1.8_1.4.6.bb [deleted file]
meta/recipes-graphics/clutter/clutter-gst.inc [deleted file]
meta/recipes-graphics/clutter/clutter-gst/enable-tests.patch [moved from meta/recipes-graphics/clutter/clutter-gst/enable_tests.patch with 58% similarity]
meta/recipes-graphics/clutter/clutter-gst/enable_tests-1.4.patch [deleted file]
meta/recipes-graphics/clutter/clutter-gst/enable_tests-1.8.patch [deleted file]

diff --git a/meta/recipes-graphics/clutter/clutter-gst-1.0.inc b/meta/recipes-graphics/clutter/clutter-gst-1.0.inc
new file mode 100644 (file)
index 0000000..f79795c
--- /dev/null
@@ -0,0 +1,23 @@
+DESCRIPTION = "Clutter GStreamer"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPLv2+"
+
+inherit clutter
+
+SRC_URI += "file://enable-tests.patch"
+
+DEPENDS = "gst-plugins-base gst-plugins-bad clutter-1.0"
+RDEPENDS_${PN} += "gst-meta-base"
+PACKAGES  =+ "${PN}-examples"
+
+EXTRA_OECONF += "--disable-introspection"
+
+FILES_${PN}          += "${libdir}/gstreamer-0.10/lib*.so"
+FILES_${PN}-dev      += "${libdir}/gstreamer-0.10/*.la"
+FILES_${PN}-dbg      += "${libdir}/gstreamer-0.10/.debug/lib*.so"
+FILES_${PN}-examples  = "${bindir}/video-player ${bindir}/video-sink"
+
+do_configure_prepend () {
+       # Disable DOLT
+       sed -i -e 's/^DOLT//' ${S}/configure.ac
+}
diff --git a/meta/recipes-graphics/clutter/clutter-gst-1.0_1.6.0.bb b/meta/recipes-graphics/clutter/clutter-gst-1.0_1.6.0.bb
new file mode 100644 (file)
index 0000000..dc5cc13
--- /dev/null
@@ -0,0 +1,9 @@
+require clutter-gst-1.0.inc
+
+SRC_URI += "file://cogl-1.14.patch"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
+                    file://clutter-gst/clutter-gst.h;beginline=1;endline=24;md5=95baacba194e814c110ea3bdf25ddbf4"
+
+SRC_URI[archive.md5sum] = "d60ab0118730cecd5dd9988ad7da034b"
+SRC_URI[archive.sha256sum] = "abc879cdd562f1640a825131405f4327a427bfe65b805ebc25d0c78909c8c622"
diff --git a/meta/recipes-graphics/clutter/clutter-gst-1.6/cogl-1.14.patch b/meta/recipes-graphics/clutter/clutter-gst-1.6/cogl-1.14.patch
new file mode 100644 (file)
index 0000000..a46b448
--- /dev/null
@@ -0,0 +1,48 @@
+From 1ae4c3e7b1e2c33892590f9ac7bf0e892a5bcbd5 Mon Sep 17 00:00:00 2001
+From: Tomas Frydrych <tomas@sleepfive.com>
+Date: Thu, 11 Oct 2012 08:53:03 +0100
+Subject: [PATCH] ClutterGstVideoSink: fix includes so we can build against
+ cogl-1.14
+
+Cogl 1.14 exposes various GL types through the public API but it does not
+pull in the GL type definitions through its public headers; specifically
+compilation will fail due to undefined GL_TEXTURE_2D. So include the headers
+the hard way.
+
+Upstream-status: Submitted @ https://bugzilla.gnome.org/show_bug.cgi?id=700509
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
+---
+ clutter-gst/clutter-gst-video-sink.c |   17 +++++++++++++++++
+ 1 file changed, 17 insertions(+)
+
+diff --git a/clutter-gst/clutter-gst-video-sink.c b/clutter-gst/clutter-gst-video-sink.c
+index 9b4b53c..f092581 100644
+--- a/clutter-gst/clutter-gst-video-sink.c
++++ b/clutter-gst/clutter-gst-video-sink.c
+@@ -42,6 +42,23 @@
+ #include "config.h"
+ #endif
+
++/*
++ * cogl-1.14 exposes generic GL types in the API, but not the actual includes.
++ */
++#include <cogl/cogl.h>
++
++#ifdef COGL_HAS_GLES1
++#include <GLES/gl.h>
++#include <GLES/glext.h>
++#elif COGL_HAS_GLES2
++#include <GLES2/gl2.h>
++#include <GLES2/gl2ext.h>
++#elif COGL_HAS_GL
++#include <GL/gl.h>
++#else
++#error Unknown cogl configuration
++#endif
++
+ #include "clutter-gst-video-sink.h"
+ #include "clutter-gst-util.h"
+ #include "clutter-gst-private.h"
+--
+1.7.10.4
+
diff --git a/meta/recipes-graphics/clutter/clutter-gst-1.8_1.4.6.bb b/meta/recipes-graphics/clutter/clutter-gst-1.8_1.4.6.bb
deleted file mode 100644 (file)
index facb0a1..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-require recipes-graphics/clutter/clutter-gst.inc
-
-PR = "r0"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
-                    file://clutter-gst/clutter-gst.h;beginline=1;endline=24;md5=95baacba194e814c110ea3bdf25ddbf4"
-
-DEPENDS += "clutter-1.8 gstreamer"
-RDEPENDS_${PN} += "gst-meta-base"
-
-SRC_URI = "http://source.clutter-project.org/sources/clutter-gst/1.4/clutter-gst-${PV}.tar.bz2 \
-           file://enable_tests-1.8.patch"
-
-S = "${WORKDIR}/clutter-gst-${PV}"
-
-SRC_URI[md5sum] = "98aeed6baa7b3a80f10e7733080eb088"
-SRC_URI[sha256sum] = "54e2966e507563bd3f123a4e25780c2487f854c6cc3df3bedc8c6b5eb45e9769"
-
-do_configure_prepend () {
-       # Disable DOLT
-       sed -i -e 's/^DOLT//' ${S}/configure.ac
-}
diff --git a/meta/recipes-graphics/clutter/clutter-gst.inc b/meta/recipes-graphics/clutter/clutter-gst.inc
deleted file mode 100644 (file)
index 702424b..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "Clutter GStreamer"
-HOMEPAGE = "http://www.clutter-project.org/"
-LICENSE = "LGPLv2+"
-
-DEPENDS = "gstreamer gst-plugins-base"
-
-FILESPATH = "${FILE_DIRNAME}/clutter-gst"
-
-PACKAGES =+ "${PN}-examples"
-FILES_${PN}-examples = "${bindir}/video-player ${bindir}/video-sink"
-
-inherit autotools pkgconfig gtk-doc
-
similarity index 58%
rename from meta/recipes-graphics/clutter/clutter-gst/enable_tests.patch
rename to meta/recipes-graphics/clutter/clutter-gst/enable-tests.patch
index 6175a521d1f3b012a39e0dd60d74c47c7acd7aa6..b3aec392e673ee150c30d4894546923bad230ccb 100644 (file)
@@ -4,6 +4,11 @@ Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
 
 Upstream-Status: Inappropriate [configuration]
 
+Imported from clutter-gst-1.8 package, git://git.openembedded.org/openembedded,
+commit ae28ee3f7a060b9e0d13154a84f2444a98490b5b, updated for clutter-gst 1.6
+
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
+
 Index: git/examples/Makefile.am
 ===================================================================
 --- git.orig/examples/Makefile.am      2011-01-31 10:14:23.000000000 +0800
@@ -11,8 +16,8 @@ Index: git/examples/Makefile.am
 @@ -1,6 +1,6 @@
  NULL = #
  
--noinst_PROGRAMS = video-player video-sink
-+bin_PROGRAMS = video-player video-sink
+-noinst_PROGRAMS = video-player video-sink video-sink-navigation
++bin_PROGRAMS = video-player video-sink video-sink-navigation
  
  INCLUDES = -I$(top_srcdir) \
           $(MAINTAINER_CFLAGS) \
diff --git a/meta/recipes-graphics/clutter/clutter-gst/enable_tests-1.4.patch b/meta/recipes-graphics/clutter/clutter-gst/enable_tests-1.4.patch
deleted file mode 100644 (file)
index 3fc1378..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Install example binary needed for core-image-clutter
-
-Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: git/examples/Makefile.am
-===================================================================
---- git.orig/examples/Makefile.am      2011-05-04 14:07:21.000000000 -0700
-+++ git/examples/Makefile.am   2011-05-04 14:24:38.625984314 -0700
-@@ -1,6 +1,6 @@
- NULL = #
--noinst_PROGRAMS = video-player video-sink audio-player
-+bin_PROGRAMS = video-player video-sink audio-player
- INCLUDES = -I$(top_srcdir) \
-          $(MAINTAINER_CFLAGS) \
diff --git a/meta/recipes-graphics/clutter/clutter-gst/enable_tests-1.8.patch b/meta/recipes-graphics/clutter/clutter-gst/enable_tests-1.8.patch
deleted file mode 100644 (file)
index de1dcc2..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
-Install example binary needed for poky-image-clutter
-
-Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
-Index: clutter-gst-1.3.8/examples/Makefile.am
-===================================================================
---- clutter-gst-1.3.8.orig/examples/Makefile.am
-+++ clutter-gst-1.3.8/examples/Makefile.am
-@@ -1,6 +1,6 @@
- NULL = #
--noinst_PROGRAMS = video-player video-sink video-sink-navigation
-+bin_PROGRAMS = video-player video-sink video-sink-navigation
- INCLUDES = -I$(top_srcdir) \
-          $(MAINTAINER_CFLAGS) \