]> code.ossystems Code Review - openembedded-core.git/commitdiff
cross-localedef-native: Use older C standards for older code
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 25 Jul 2015 23:19:08 +0000 (23:19 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 26 Jul 2015 08:08:44 +0000 (09:08 +0100)
This older code needs specific compiler options to allow it to work
with gcc 5. These options are used in the 2.21 recipe in master/fido
so this simply backports them.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glibc/cross-localedef-native_2.20.bb

index ccf56a9415af0624e46b8994a4529e164ed608e4..66119b1b5e418a72ff5cf3d1ff2fdae90c2b7847 100644 (file)
@@ -39,7 +39,7 @@ SRCREV_localedef = "c833367348d39dad7ba018990bfdaffaec8e9ed3"
 S = "${WORKDIR}/git"
 
 EXTRA_OECONF = "--with-glibc=${S}"
-CFLAGS += "-DNOT_IN_libc=1"
+CFLAGS += "-fgnu89-inline -std=gnu99 -DNOT_IN_libc=1"
 
 do_configure () {
        ${S}/localedef/configure ${EXTRA_OECONF}