]> code.ossystems Code Review - openembedded-core.git/commitdiff
expect: Fix segfaults when Expect clib is used directly from C program
authorLi Zhou <li.zhou@windriver.com>
Fri, 29 Sep 2017 02:00:21 +0000 (10:00 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 8 Nov 2017 22:23:43 +0000 (22:23 +0000)
Fix segfaults if Tcl is built with stubs and Expect clib function is used
directly from C program.

Signed-off-by: Li Zhou <li.zhou@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/expect/expect/0001-expect-Fix-segfaults-if-Tcl-is-built-with-stubs-and-.patch [new file with mode: 0644]
meta/recipes-devtools/expect/expect_5.45.bb

diff --git a/meta/recipes-devtools/expect/expect/0001-expect-Fix-segfaults-if-Tcl-is-built-with-stubs-and-.patch b/meta/recipes-devtools/expect/expect/0001-expect-Fix-segfaults-if-Tcl-is-built-with-stubs-and-.patch
new file mode 100644 (file)
index 0000000..b1d322d
--- /dev/null
@@ -0,0 +1,91 @@
+From f0049b4b2ea55b3b3c53bf6f0275654801c755d2 Mon Sep 17 00:00:00 2001
+From: Li Zhou <li.zhou@windriver.com>
+Date: Thu, 28 Sep 2017 15:54:55 +0800
+Subject: [PATCH] expect: Fix segfaults if Tcl is built with stubs and Expect
+ is used directly from C program
+
+Description: This dirty hack fixes segfaults if Tcl is built with stubs
+ and Expect is used directly from C program.
+Bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=588817
+Example:
+ #include <stdio.h>
+ #include <tcl8.5/expect.h>
+ int main()
+ {
+     FILE *pipe;
+     char *some_command = "uname";
+     char datum;
+     pipe = exp_popen(some_command);
+     if (pipe == NULL) return 1;
+     while ((datum = getc (pipe)) != EOF)
+       printf("%c",datum);
+ }
+Example:
+ #include <stdio.h>
+ #include "expect.h"
+ main()
+ {
+     int fd = 0;
+     fd = exp_spawnl("echo", "echo", "Hello User: Whats up?", (char*) 0);
+     switch (exp_expectl(fd, exp_regexp, "ser:", 1, exp_end)) {
+       case 1: {
+           printf("GOT ser:\n");
+           break;
+       }
+       default: {
+           printf("DEFAULT\n");
+           return 1;
+       }
+     }
+     printf("Normal Exit\n");
+     return 0;
+ }
+Author: Sergei Golovan <sgolovan@debian.org>
+
+Upstream-Status: Pending
+This patch is backported from fedora changes for expect:
+http://pkgs.fedoraproject.org/cgit/rpms/expect.git/commit/
+?h=master&id=b6737eed550be93182f2ed194e836a6cbbcf4fa3
+Signed-off-by: Li Zhou <li.zhou@windriver.com>
+---
+ exp_clib.c | 10 +++++++---
+ 1 file changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/exp_clib.c b/exp_clib.c
+index 172c05e..19341d5 100644
+--- a/exp_clib.c
++++ b/exp_clib.c
+@@ -114,7 +114,11 @@ extern unsigned long      strtoul _ANSI_ARGS_((CONST char *string,
+ #include <stdlib.h>           /* for malloc */
+ #endif
+-#include <tcl.h>
++#define ckalloc(x) Tcl_Alloc(x)
++#define ckfree(x) Tcl_Free(x)
++extern char *Tcl_ErrnoMsg(int err);
++extern char *Tcl_Alloc(unsigned int size);
++extern void Tcl_Free(char *ptr);
+ #include "expect.h"
+ #define TclRegError exp_TclRegError
+@@ -389,7 +393,7 @@ char *exp;
+               FAIL("regexp too big");
+       /* Allocate space. */
+-      r = (regexp *)ckalloc(sizeof(regexp) + (unsigned)rcstate->regsize);
++      r = (regexp *)malloc(sizeof(regexp) + (unsigned)rcstate->regsize);
+       if (r == NULL)
+               FAIL("out of space");
+@@ -399,7 +403,7 @@ char *exp;
+       rcstate->regcode = r->program;
+       regc(MAGIC, rcstate);
+       if (reg(0, &flags, rcstate) == NULL) {
+-        ckfree ((char*) r);
++        free((char*) r);
+         return(NULL);
+       }
+-- 
+1.9.1
+
index e2d24e8d8582b09a4fe7882ee057844f5ab135cc..c9f5aba897056d1d26a94aa6b8f9893a5ee743c1 100644 (file)
@@ -26,6 +26,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/${PV}/${BPN}${PV}.tar.gz \
            file://01-example-shebang.patch \
            file://0001-expect-install-scripts-without-using-the-fixline1-tc.patch \
            file://0001-Resolve-string-formatting-issues.patch \
+           file://0001-expect-Fix-segfaults-if-Tcl-is-built-with-stubs-and-.patch \
           "
 SRC_URI[md5sum] = "44e1a4f4c877e9ddc5a542dfa7ecc92b"
 SRC_URI[sha256sum] = "b28dca90428a3b30e650525cdc16255d76bb6ccd65d448be53e620d95d5cc040"