]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev: don't mount with -o sync
authorJesse Zhang <sen.zhang@windriver.com>
Fri, 21 Sep 2012 18:21:34 +0000 (13:21 -0500)
committerScott Garman <scott.a.garman@intel.com>
Tue, 2 Oct 2012 01:56:19 +0000 (18:56 -0700)
mount.sh mounts all partitions with -o sync, which is bad for system
performance.

(From OE-Core rev: d49cf73754150b50a911d326aaa666f5da78855c)

Signed-off-by: Jesse Zhang <sen.zhang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/udev/udev/mount.sh
meta/recipes-core/udev/udev_164.bb

index 53fefa368103ce00cfee32a37125344f6895f3e3..c13b8bbb3be4fce111853d318ffc9c34c427ffb3 100644 (file)
@@ -23,7 +23,7 @@ automount() {
 
        ! test -d "/media/$name" && mkdir -p "/media/$name"
        
-       if ! $MOUNT -t auto -o sync $DEVNAME "/media/$name"
+       if ! $MOUNT -t auto $DEVNAME "/media/$name"
        then
                #logger "mount.sh/automount" "$MOUNT -t auto $DEVNAME \"/media/$name\" failed!"
                rm_dir "/media/$name"
index c5813ecb472bdccaaaa3529524d8ca5d18b4e908..0462ff205d952eab419bc0a0d6ed65872079d302 100644 (file)
@@ -1,6 +1,6 @@
 include udev.inc
 
-PR = "r13"
+PR = "r14"
 
 SRC_URI += "file://udev-166-v4l1-1.patch"