]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: fix read-only-rootfs-hook.sh to start earlier
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Wed, 10 Apr 2013 15:38:07 +0000 (15:38 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Apr 2013 15:49:08 +0000 (16:49 +0100)
Mount /var/volatile ourselves so that we can set up the writable area
first. This fixes the urandom service not starting properly when
read-only-rootfs is enabled.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/initscripts/initscripts-1.0/read-only-rootfs-hook.sh
meta/recipes-core/initscripts/initscripts_1.0.bb

index 4f3e0d96452f440d2a84978e0c183e06fbf881eb..9cf092167033aeb3c0c4d889bfbec1af0f6cb71d 100644 (file)
@@ -5,6 +5,7 @@
 [ "$ROOTFS_READ_ONLY" = "no" ] && exit 0
 
 if [ "$1" = "start" ] ; then
+       grep -q "tmpfs /var/volatile" /proc/mounts || mount /var/volatile
        mkdir -p /var/volatile/lib
        cp -a /var/lib/* /var/volatile/lib
        mount --bind /var/volatile/lib /var/lib
index 649e18269e004f5118f0cd7ae5a389b13b7cbe71..531b2b62dfee0d476fcdae6751a8cdac88317363 100644 (file)
@@ -118,7 +118,7 @@ do_install () {
        update-rc.d -r ${D} bootmisc.sh start 55 S .
        update-rc.d -r ${D} sysfs.sh start 02 S .
        update-rc.d -r ${D} populate-volatile.sh start 37 S .
-       update-rc.d -r ${D} read-only-rootfs-hook.sh start 41 S .
+       update-rc.d -r ${D} read-only-rootfs-hook.sh start 29 S .
        update-rc.d -r ${D} devpts.sh start 38 S .
        if [ "${TARGET_ARCH}" = "arm" ]; then
                update-rc.d -r ${D} alignment.sh start 06 S .