]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit: Fix makefile bug found with clang
authorKhem Raj <raj.khem@gmail.com>
Sat, 22 Aug 2015 15:58:10 +0000 (08:58 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 30 Aug 2015 11:34:12 +0000 (12:34 +0100)
This is due to specifying .h files on linker cmdline
clang driver is picky about it, and its not entirely correct
either

(From OE-Core rev: de45b5e68faeefe3d68818d456f280b98f397634)

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/sysvinit/sysvinit/0001-This-fixes-an-issue-that-clang-reports-about-mutlipl.patch [new file with mode: 0644]
meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb

diff --git a/meta/recipes-core/sysvinit/sysvinit/0001-This-fixes-an-issue-that-clang-reports-about-mutlipl.patch b/meta/recipes-core/sysvinit/sysvinit/0001-This-fixes-an-issue-that-clang-reports-about-mutlipl.patch
new file mode 100644 (file)
index 0000000..f35c15c
--- /dev/null
@@ -0,0 +1,52 @@
+From 36ac97bfe51797458442a6035219a504a42e703a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 21 Aug 2015 10:56:40 -0700
+Subject: [PATCH] This fixes an issue that clang reports about mutliple output
+ files
+
+Issue is that we are passing .h file to link step as seen below.
+
+| arm-oe-linux-gnueabi-clang  -march=armv7-a -mthumb  -mfloat-abi=hard
+-mfpu=neon-vfpv4 -mtune=cortex-a7 -D__extern_always_inline=inline
+-no-integrated-as
+--sysroot=/mnt/home/kraj/work/angstrom/sources/openembedded-core/build/tmp-glibc/sysroots/raspberrypi2
+-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed  halt.o ifdown.o hddown.o
+utmp.o reboot.h   -o halt
+| clang-3.7: error: cannot specify -o when generating multiple output
+files
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index e77ed5f..a6f9f40 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -103,9 +103,9 @@ all:               $(BIN) $(SBIN) $(USRBIN)
+ init:         LDLIBS += $(INITLIBS) $(STATIC)
+ init:         init.o init_utmp.o
+-halt:         halt.o ifdown.o hddown.o utmp.o reboot.h
++halt:         halt.o ifdown.o hddown.o utmp.o
+-last:         last.o oldutmp.h
++last:         last.o
+ mesg:         mesg.o
+@@ -120,7 +120,7 @@ sulogin:   sulogin.o
+ wall:         dowall.o wall.o
+-shutdown:     dowall.o shutdown.o utmp.o reboot.h
++shutdown:     dowall.o shutdown.o utmp.o
+ bootlogd:     LDLIBS += -lutil
+ bootlogd:     bootlogd.o
+-- 
+2.1.4
+
index 6709a9be3ac6e84484fa8435b4ea06ff17bfd322..5dfe39e23381baabba6df0b1acef3a59320c12b3 100644 (file)
@@ -13,6 +13,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/sysvinit/sysvinit-${PV}.tar.bz2 \
            file://install.patch \
            file://crypt-lib.patch \
            file://pidof-add-m-option.patch \
+           file://0001-This-fixes-an-issue-that-clang-reports-about-mutlipl.patch \
            file://rcS-default \
            file://rc \
            file://rcS \