]> code.ossystems Code Review - openembedded-core.git/commitdiff
gst-plugins-bad: upgrade to 0.10.8
authorRoss Burton <ross@openedhand.com>
Sun, 3 Aug 2008 13:47:50 +0000 (13:47 +0000)
committerRoss Burton <ross@openedhand.com>
Sun, 3 Aug 2008 13:47:50 +0000 (13:47 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5014 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gstreamer/gst-plugins-bad-0.10.5/ivorbisdec.patch [deleted file]
meta/packages/gstreamer/gst-plugins-bad_0.10.8.bb [moved from meta/packages/gstreamer/gst-plugins-bad_0.10.5.bb with 85% similarity]

diff --git a/meta/packages/gstreamer/gst-plugins-bad-0.10.5/ivorbisdec.patch b/meta/packages/gstreamer/gst-plugins-bad-0.10.5/ivorbisdec.patch
deleted file mode 100644 (file)
index 047c186..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-diff -urNd ../gst-plugins-bad0.10-0.10.3+cvs20060918/ext/ivorbis/vorbisdec.h ext/ivorbis/vorbisdec.h
---- ../gst-plugins-bad0.10-0.10.3+cvs20060918/ext/ivorbis/vorbisdec.h  1970-01-01 01:00:00.000000000 +0100
-+++ ext/ivorbis/vorbisdec.h    2006-09-20 17:26:46.000000000 +0100
-@@ -0,0 +1,87 @@
-+/* -*- c-basic-offset: 2 -*-
-+ * GStreamer
-+ * Copyright (C) <1999> Erik Walthinsen <omega@cse.ogi.edu>
-+ *
-+ * Tremor modifications <2006>:
-+ *   Chris Lord, OpenedHand Ltd. <chris@openedhand.com>, http://www.o-hand.com/
-+ *
-+ * This library is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU Library General Public
-+ * License as published by the Free Software Foundation; either
-+ * version 2 of the License, or (at your option) any later version.
-+ *
-+ * This library is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-+ * Library General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU Library General Public
-+ * License along with this library; if not, write to the
-+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-+ * Boston, MA 02111-1307, USA.
-+ */
-+
-+
-+#ifndef __GST_IVORBIS_DEC_H__
-+#define __GST_IVORBIS_DEC_H__
-+
-+
-+#include <gst/gst.h>
-+#include <tremor/ivorbiscodec.h>
-+
-+G_BEGIN_DECLS
-+
-+#define GST_TYPE_IVORBIS_DEC \
-+  (gst_ivorbis_dec_get_type())
-+#define GST_IVORBIS_DEC(obj) \
-+  (G_TYPE_CHECK_INSTANCE_CAST((obj),GST_TYPE_IVORBIS_DEC,GstIVorbisDec))
-+#define GST_IVORBIS_DEC_CLASS(klass) \
-+  (G_TYPE_CHECK_CLASS_CAST((klass),GST_TYPE_IVORBIS_DEC,GstIVorbisDecClass))
-+#define GST_IS_IVORBIS_DEC(obj) \
-+  (G_TYPE_CHECK_INSTANCE_TYPE((obj),GST_TYPE_IVORBIS_DEC))
-+#define GST_IS_IVORBIS_DEC_CLASS(klass) \
-+  (G_TYPE_CHECK_CLASS_TYPE((klass),GST_TYPE_IVORBIS_DEC))
-+
-+typedef struct _GstIVorbisDec GstIVorbisDec;
-+typedef struct _GstIVorbisDecClass GstIVorbisDecClass;
-+
-+/**
-+ * GstIVorbisDec:
-+ *
-+ * Opaque data structure.
-+ */
-+struct _GstIVorbisDec {
-+  GstElement            element;
-+
-+  GstPad *              sinkpad;
-+  GstPad *              srcpad;
-+
-+  vorbis_dsp_state      vd;
-+  vorbis_info           vi;
-+  vorbis_comment        vc;
-+  vorbis_block          vb;
-+  guint64               granulepos;
-+
-+  gboolean              initialized;
-+
-+  GList                 *queued;
-+
-+  GstSegment          segment;
-+  gboolean            discont;
-+
-+  GstClockTime          cur_timestamp; /* only used with non-ogg container formats */
-+  GstClockTime          prev_timestamp; /* only used with non-ogg container formats */
-+
-+  GList                       *pendingevents;
-+  GstTagList          *taglist;
-+};
-+
-+struct _GstIVorbisDecClass {
-+  GstElementClass parent_class;
-+};
-+
-+GType gst_ivorbis_dec_get_type(void);
-+
-+G_END_DECLS
-+
-+#endif /* __GST_IVORBIS_DEC_H__ */
similarity index 85%
rename from meta/packages/gstreamer/gst-plugins-bad_0.10.5.bb
rename to meta/packages/gstreamer/gst-plugins-bad_0.10.8.bb
index d6023aae1887058d752bc68ae53ce1c92a06e87a..78192dfa0bf095ad67b35f32ccd9ae0d8df4796a 100644 (file)
@@ -1,12 +1,9 @@
 require gst-plugins.inc
 DEPENDS += "gst-plugins-base libmusicbrainz tremor"
-PR = "r6"
 
 EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl --disable-cdaudio \
                --with-plugins=musicbrainz,wavpack,ivorbis"
 
-SRC_URI += " file://ivorbisdec.patch;patch=1;pnum=0"
-
 ARM_INSTRUCTION_SET = "arm"
 
 do_configure_prepend() {