]> code.ossystems Code Review - openembedded-core.git/commitdiff
mmc-utils: fix compilation failure for mips64 target.
authorChen Qi <Qi.Chen@windriver.com>
Tue, 6 May 2014 07:53:12 +0000 (15:53 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 May 2014 12:42:07 +0000 (13:42 +0100)
This patch fixes mmc-utils compilation failure for qemumips64.
Remove the 'include <asm-generic/int-ll64.h>' line from mmc.h,
because this file is automatically included if _MIPS_SZLONG
is not 64, otherwise, <asm-generic/int-l64.h> is included.

Expicitly including <asm-generic/int-ll64.h> will cause the
compilation failure for mips64 target.

[YOCTO #6267]

(From OE-Core rev: 5477cc86015be24cc5b232ac1f8c67cd8b65a740)

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/mmc/mmc-utils/0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch [new file with mode: 0644]
meta/recipes-devtools/mmc/mmc-utils_git.bb

diff --git a/meta/recipes-devtools/mmc/mmc-utils/0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch b/meta/recipes-devtools/mmc/mmc-utils/0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch
new file mode 100644 (file)
index 0000000..1724de5
--- /dev/null
@@ -0,0 +1,28 @@
+Upstream-Status: Pending
+
+mmc.h: don't include <asm-generic/int-ll64.h>
+
+Including this file causes a compile failure for qemumips64.
+This file is not needed to be explicitly included, because it will be
+included by the <linux/mmc/ioctl.h> file if _MIPS_SZLONG is not 64.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ mmc.h |    1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/mmc.h b/mmc.h
+index 9871d62..3df2cdf 100644
+--- a/mmc.h
++++ b/mmc.h
+@@ -14,7 +14,6 @@
+  * Boston, MA 021110-1307, USA.
+  */
+-#include <asm-generic/int-ll64.h>
+ #include <linux/mmc/ioctl.h>
+ #include <stdio.h>
+-- 
+1.7.9.5
+
index abde4b1110c6056095a3072795f6bd40424497a2..d88520c78633392ce8c688aee91596ec20179a2d 100644 (file)
@@ -8,8 +8,8 @@ SRCREV = "11f2ceabc4ad3f0dd568e0ce68166e4803e0615b"
 
 PV = "0.1"
 
-SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;protocol=git;branch=${BRANCH}"
-
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;protocol=git;branch=${BRANCH} \
+           file://0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch"
 
 S = "${WORKDIR}/git"