]> code.ossystems Code Review - openembedded-core.git/commitdiff
consolekit: Add 0.3.0 from OE but disable policykit interaction
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 22 May 2009 16:30:04 +0000 (17:30 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 22 May 2009 16:30:04 +0000 (17:30 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta-moblin/packages/consolekit/consolekit_0.3.0.bb [new file with mode: 0644]
meta-moblin/packages/consolekit/files/nopolkit.patch [new file with mode: 0644]

diff --git a/meta-moblin/packages/consolekit/consolekit_0.3.0.bb b/meta-moblin/packages/consolekit/consolekit_0.3.0.bb
new file mode 100644 (file)
index 0000000..b4656c0
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "ConsoleKit is a framework for defining and tracking users, login sessions, and seats."
+LICENSE = "GPLv2"
+DEPENDS = "dbus"
+
+inherit gnome
+
+SRC_URI = "http://people.freedesktop.org/~mccann/dist/ConsoleKit-${PV}.tar.bz2 \
+           file://nopolkit.patch;patch=1"
+S = "${WORKDIR}/ConsoleKit-${PV}"
+
+do_stage () {
+       autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/ConsoleKit ${datadir}/dbus-1 ${datadir}/PolicyKit"
+
+
+
+
diff --git a/meta-moblin/packages/consolekit/files/nopolkit.patch b/meta-moblin/packages/consolekit/files/nopolkit.patch
new file mode 100644 (file)
index 0000000..bebbcaf
--- /dev/null
@@ -0,0 +1,16 @@
+Index: ConsoleKit-0.3.0/configure.ac
+===================================================================
+--- ConsoleKit-0.3.0.orig/configure.ac 2009-05-22 12:53:27.000000000 +0100
++++ ConsoleKit-0.3.0/configure.ac      2009-05-22 12:53:56.000000000 +0100
+@@ -55,10 +55,7 @@
+   gthread-2.0 >= $GLIB_REQUIRED_VERSION
+ )
+-PKG_CHECK_MODULES(POLKIT,
+-  polkit >= $POLKIT_REQUIRED_VERSION,
+-  have_polkit=yes,
+-  have_polkit=no)
++have_polkit=no
+ if test "x$have_polkit" = "xyes" ; then
+        AC_DEFINE(HAVE_POLKIT, [], [Define if we have polkit])
+ fi