]> code.ossystems Code Review - openembedded-core.git/commitdiff
dnf: add /usr/bin/dnf symlink that points to /usr/bin/dnf-2
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Thu, 16 Mar 2017 13:19:07 +0000 (15:19 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 Mar 2017 11:55:24 +0000 (11:55 +0000)
All documentation refers to dnf binary as 'dnf' yet make install
does not create one - it's done by Fedora's spec file when building
the rpm. Let's replicate this behavior.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/lib/oe/package_manager.py
meta/lib/oeqa/runtime/cases/dnf.py
meta/recipes-devtools/dnf/dnf_git.bb

index eeb4c76071a78cbcade073071d0b754c80cae9de..ae6849bce3fcce9fcc70690c279812f362115d5d 100644 (file)
@@ -677,7 +677,7 @@ class RpmPM(PackageManager):
     def _invoke_dnf(self, dnf_args, fatal = True, print_output = True ):
         os.environ['RPM_ETCCONFIGDIR'] = self.target_rootfs
 
-        dnf_cmd = bb.utils.which(os.getenv('PATH'), "dnf-2")
+        dnf_cmd = bb.utils.which(os.getenv('PATH'), "dnf")
         standard_dnf_args = (["-v", "--rpmverbosity=debug"] if self.d.getVar('ROOTFS_RPM_DEBUG') else []) + ["-y",
                              "-c", oe.path.join(self.target_rootfs, "etc/dnf/dnf.conf"),
                              "--setopt=reposdir=%s" %(oe.path.join(self.target_rootfs, "etc/yum.repos.d")),
index 77e7eb9450727de658b028952bd7973f8ec948f8..59a263dc63ab021af9523fc8884774474ebec474 100644 (file)
@@ -12,7 +12,7 @@ from oeqa.runtime.decorator.package import OEHasPackage
 class DnfTest(OERuntimeTestCase):
 
     def dnf(self, command, expected = 0):
-        command = 'dnf-2 %s' % command
+        command = 'dnf %s' % command
         status, output = self.target.run(command, 1500)
         message = os.linesep.join([command, output])
         self.assertEqual(status, expected, message)
index 018352a6c9b3f76f75b7f5bb8856baf19056e05f..3a2cb635e40a82fbfeb283030247b3f7c75a0e52 100644 (file)
@@ -30,9 +30,17 @@ EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}"
 BBCLASSEXTEND = "native nativesdk"
 RDEPENDS_${PN}_class-target += "python-core python-codecs python-netclient python-email python-threading python-distutils librepo python-shell python-subprocess libcomps libdnf python-sqlite3 python-compression python-pygpgme python-backports-lzma python-rpm python-iniparse python-json python-importlib python-curses python-argparse"
 
+# Create a symlink called 'dnf' as 'make install' does not do it, but
+# .spec file in dnf source tree does (and then Fedora and dnf documentation
+# says that dnf binary is plain 'dnf').
+do_install_append() {
+        ln -s -r ${D}/${bindir}/dnf-2 ${D}/${bindir}/dnf
+        ln -s -r ${D}/${bindir}/dnf-automatic-2 ${D}/${bindir}/dnf-automatic
+}
+
 # Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
 do_install_append_class-native() {
-        create_wrapper ${D}/${bindir}/dnf-2 \
+        create_wrapper ${D}/${bindir}/dnf \
                 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
                 RPM_NO_CHROOT_FOR_SCRIPTS=1
 }