]> code.ossystems Code Review - openembedded-core.git/commitdiff
openobex: 1.2 -> 1.5
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 31 Jul 2009 09:02:03 +0000 (10:02 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 31 Jul 2009 09:02:03 +0000 (10:02 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/openobex/files/libusb_crosscompile_check.patch
meta/packages/openobex/openobex_1.5.bb [moved from meta/packages/openobex/openobex_1.2.bb with 59% similarity]

index c28921b8ca0a9d6a43c5e0e094d8df1ae7f12ec6..20ac70bd1e330d9616d2766fdcda539e2998a765 100644 (file)
@@ -1,12 +1,13 @@
-diff -Naur openobex-1.2_old/acinclude.m4 openobex-1.2/acinclude.m4
---- openobex-1.2_old/acinclude.m4      2006-03-07 19:57:49.000000000 +0200
-+++ openobex-1.2/acinclude.m4  2006-04-18 23:07:25.000000000 +0300
-@@ -195,7 +195,7 @@
-       if (test "${usb_enable}" = "yes" && test "${usb_found}" = "yes"); then
-               AC_DEFINE(HAVE_USB, 1, [Define if system supports USB and it's enabled])
--              AC_CHECK_FILE(${usb_prefix}/lib/pkgconfig/libusb.pc, REQUIRES="$REQUIRES libusb")
+Index: openobex-1.5/acinclude.m4
+===================================================================
+--- openobex-1.5.orig/acinclude.m4     2009-02-08 18:30:22.000000000 +0000
++++ openobex-1.5/acinclude.m4  2009-07-31 09:55:46.000000000 +0100
+@@ -158,7 +158,7 @@
+               ;;
+       *)
+               PKG_CHECK_MODULES(USB, libusb, usb_lib_found=yes, AC_MSG_RESULT(no))
+-              AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="libusb")
 +              REQUIRES="libusb"
-       fi
-       AM_CONDITIONAL(APPS, test "${apps_enable}" = "yes")
+               ;;
+       esac
+       AC_SUBST(USB_CFLAGS)
similarity index 59%
rename from meta/packages/openobex/openobex_1.2.bb
rename to meta/packages/openobex/openobex_1.5.bb
index 1824fc743e5d1ebb0e41a0af1beb6f070baa6742..8fc7e6dc7da2210b1d929c82b1f51b2b6f3f1b81 100644 (file)
@@ -3,28 +3,19 @@ Object Exchange (OBEX) protocol."
 HOMEPAGE = "http://openobex.triq.net"
 SECTION = "libs"
 PROVIDES = "openobex-apps"
-DEPENDS = "libusb bluez-libs"
+DEPENDS = "libusb bluez4"
 LICENSE = "GPL"
 PR = "r4"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/bluetooth/openobex-${PV}.tar.gz \
            file://disable-cable-test.patch;patch=1 \
           file://libusb_crosscompile_check.patch;patch=1"
 
-inherit autotools binconfig pkgconfig
+inherit autotools_stage binconfig pkgconfig
 
 EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
                 --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
 
-do_stage() {
-       oe_libinstall -so -C lib libopenobex ${STAGING_LIBDIR}
-       ln -sf libopenobex.so ${STAGING_LIBDIR}/libopenobex-1.2.so
-       install -d ${STAGING_INCDIR}/openobex
-       install -m 0644 include/*.h ${STAGING_INCDIR}/openobex/
-       install -d ${STAGING_DATADIR}/aclocal
-       install -m 0644 openobex.m4 ${STAGING_DATADIR}/aclocal/
-}
-
 # how to stop shlibrename from renaming -apps?
 PACKAGES += "openobex-apps"
 FILES_${PN} = "${libdir}/lib*.so.*"