]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr-util: Allow use in SDK
authorTimo Mueller <timo.mueller@bmw-carit.de>
Tue, 3 Feb 2015 12:21:28 +0000 (13:21 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 7 Feb 2015 13:30:56 +0000 (13:30 +0000)
This adds 'nativesdk' in the BBCLASSEXTEND.

Building apr-util for the SDK requires that some paths in the rules.mk
file are fixed to point to the actual enviroment. These include pointing
the apr configuration variables to the actual apr builddir and
correcting the name of the libtool.

Signed-off-by: Timo Mueller <timo.mueller@bmw-carit.de>
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/apr/apr-util_1.5.4.bb

index ac01b63ecd8ccb66b1c140d8cc3cdda7fc30e5b6..6a14d14d41abd1adac32098ae23d72a82dfde4e7 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://apr.apache.org/"
 SECTION = "libs"
 DEPENDS = "apr expat gdbm"
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=519e0a18e03f7c023070568c14b077bb \
@@ -49,6 +49,17 @@ do_configure_append_class-native() {
        sed -i "s#LIBTOOL=\$(apr_builddir)#LIBTOOL=${STAGING_BINDIR_NATIVE}#" ${B}/build/rules.mk
 }
 
+do_configure_prepend_class-nativesdk() {
+       cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+}
+
+do_configure_append_class-nativesdk() {
+       sed -i "s#\(apr_builddir\)=.*#\1=${STAGING_DATADIR}/build-1#" ${S}/build/rules.mk
+       sed -i "s#\(apr_builders\)=.*#\1=${STAGING_DATADIR}/build-1#" ${S}/build/rules.mk
+       sed -i "s#\(top_builddir\)=.*#\1=${STAGING_DATADIR}/build-1#" ${S}/build/rules.mk
+       sed -i "s#\(LIBTOOL=\$(apr_builddir)\).*#\1/libtool#" ${S}/build/rules.mk
+}
+
 FILES_${PN}     += "${libdir}/apr-util-1/apr_dbm_gdbm-1.so"
 FILES_${PN}-dev += "${libdir}/aprutil.exp ${libdir}/apr-util-1/apr_dbm_gdbm.so* ${libdir}/apr-util-1/apr_dbm_gdbm.la"
 FILES_${PN}-dbg += "${libdir}/apr-util-1/.debug/*"